Qt World Summit: Register Today!

[Solved] Access is denied for run application in QtCreator

  • Hi,

    I'm using Qt 4.7 with CMake 2.8. When I run the application in QtCreator, sometimes I'm getting following compile output and project can not compile further.

    @07:55:57: Starting: "C:\QtSDK\mingw\bin\mingw32-make.exe"
    [ 11%] Built target crypto
    mingw32-make.exe[1]: *** Access is denied.
    . Stop.
    mingw32-make.exe[1]: *** Waiting for unfinished jobs....@

    Have any solution?

    Thanks in advance.

  • Moderators

    mostly this error occurs when you didn't quit your application and want to rebuild the exe while it's still running in the background. ;)

  • @ raven-worx,

    Thank you very much for reply me. My task manager displays several running mingw32-make.exes .

    I don't know what I have to do. Can you help me?

    I googled for a solution, some people says this is because of virus guard.

    Thanks again.

  • Moderators

    i'm not talking about "mingw32-make.exe" but instead of your application exe (in your case probably crypto.exe?) ... or whatever you are building. The file may still be in use...

    If you are sure it's not your application exe then the problem is somewhere else. But check this first.

  • Best is probably to restart your system at this time.
    As raven-worx commented mingw32-make is not not the real problem. It is your application which is still running.
    One harmless reason could be that the application is still cleaning up. Especially when running an application in the debugger, it is still very fast to allocate large amounts of memory. However, the cleanup may take ages. I had instances where the cleanup took the system several minutes.

  • @ raven-worx, koahnig

    Thank you very much for both of you.

    I couldn't find my application is running when I try to run it again.

    But I got some idea from your answers. I'm using databases and some times I open them in SQLite Expert while program is running. It might be a problem.
    I'll check.

    Thanks again.

  • I checked that.

    But unfortunately it is not the issue. :(

    I created a sample project and run few times. It is also sometimes denying the Access.

    Is it due to the Virus guard?

    I'm using Kaspersky.

    Thanks for helping me.

  • Hi all,

    Finally I found the source of the bug. But still don't know the solution except avoid the cause.

    When I'm building the project , 3 instances of mingw32-make.exes start to run. After build they all dies. No problem. :)

    Second time I stop the building by click the small x in build. All 3 created processors dies but it takes some time. No problem. :)

    Third time I stop building and start building again just after few milliseconds. First 3 mingw32-make.exes haven't got enough time to die. But another 3 created. Now have 6 running mingw32-make.exes. Problem occurred. :(

    Problem get worse when building stops due to the running exes. Even access is denied it creates another 3 instances of mingw32-make.exes.

    So time to time access is denying and gradually collect mingw32-make.exes which cause to stuck my PC.

    This is cause of the error but I don't know any other solution rather than stop clicking small x or wait while for second build.

    Thank you all

  • Dear friends,

    This is due to virus guard (Kaspersky Endpoint Security 10 for Windows). I turn it off. Now working well.

Log in to reply