Unable to build for Symbian with new Qt SDK 1.1 Tech Preview

  • I have a previous project that builds ok under the old Nokia Qt SDK 1.0 + (Symbian from qt.nokia.com that's based on the S60 5th version of SDK) . I have opened this project under the new Qt SDK 1.1 Tech Preview and have changed the configuration to Symbian^3 Release. The project builds without error but the .sis isn't created.

    Stepping back and trying something simpler, I created a new 'empty' (QT Quick Application) project using the new Qt SDK 1.1 Tech Preview and set the configuration to Symbian^3 and this does the same. It builds but there is no .sis.

    In both cases the build is short and suggests that everything isn't being built.

    As I can't seem to attach a file to this post, I have put the build log for the 'empty' project at http://simonjudge.com/qtlog.txt


  • Moderators

    The new Qt Creator does not build sis files as part of the build steps. So it is normal that you do not have a package right after building:-) We had lots of people complaining that they wanted to check their code for compiler warnings and did not weant to sit through the packaging step.

    Check the Run Settings for the deployment steps: The packaging happens there now.

  • ummm. I found the auto build for the sis useful. When I click on the 'run' icon to start a deploy I get...

    Unable to acquire a device for port ''. It appears to be in use.
    Error while building project Test2 (target: Symbian Device)
    When executing build step 'Deploy'

    ... presumably because I am not connecting a real device (and don't want to)

    How can I just create the SIS (from the IDE)?



  • Moderators

    Add a new deployment configuration that only has the packaging step.

  • Thanks for the help but...

    How do I do this? All the Run stages are removable except the first one that has the device serial port mentioned.

    I have also tried to connect a C7 but while it connects (in PC Suite), it's not recognised by Creator.


  • Also, I have tried to create from the Symbian 4.7.1 command line (as per the help) in the project directory...

    qmake && make release-gcce

    ... and I get...

    Warning: No valid release platforms in SYMBIAN_PLATFORMS ()
    Most likely required compiler(s) are not properly installed.
    make: *** No rule to make target `release-gcce'. Stop.

    Every which way, everything is broken.


  • Moderators

    The first part of the Symbian deploy configuration is just generic setup. Just remove the "Deploy to Device" step and you should be fine.

    Is the device listed on the "Device serial port" combobox? Do you have TRK running on your C7? That is required to display the device information (available only after clicking on the little I icon).

    Did you set up your environment when trying to build in the command line?

  • Moderators

    Of course you can just leave the settings alone and have creator build the package before it runs your code on the device:-)

  • Great. Deleting the later (in the list) deploy fixed it.

    I am less interested in the C7 connection and command line now that I have a sis.

    Thanks for your help


  • Hi Tobias,
    I'm very new to Qt development, I have installed the SDK 1.1 BETA and writing samples for S60 5th version.
    I'm trying to connect the nokia5233 device with the QtCreator.
    when I run the sample app in the QtCreator it is giving the error "Unable to acquire a device for port ‘’. It appears to be in use".
    Above you mentioned "Add a new deployment configuration that only has the packaging step". Please let me know how to do this in QtCreator.

    Just so you know, I have installed the Qt,OpenC, TRK,..etc on the device.

    Thanks in advance,


  • Welcome bhupathirao, I suggest you start a new thread in the Tools forum with your question since it's not all that related to this one.

  • Moderators

    bhupathirao: Please check the documentation we ship with Qt Creator: That does explain all these details.

    The Deployment settings are in Project mode, Run Settings.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.