No Debugger Setup for Mac OS X



  • I am fairly new to Qt. I got Qt working and operating a while ago, but when I updated my operating system to OS 10.8 it caused some problems in Qt. I tried uninstalling it and reinstalling it, but all of my new Qt Kits do not have an auto-detected debugger set up. I've scoured the web and forums and any of the solutions I found are geared toward Windows. Am I installing Qt wrong or is there a quick clone way to fix this issue? I tried downloading the debugging libraries for 4.8.

    Thanks in advance.

    Sean



  • Did you build the command line tools for XCode after updating your OS?



  • I did download the command line tools for XCode. From the digging I've done it just seems that the installation files came without a gdb engine.



  • You have to not only download them but install them also.

    'ls -l /usr/bin/gdb' to see if it is installed.

    I gather that in Qt Creator 3.0 lldb will be supported....



  • usr/bin/gdb is not installed. How do I go about installing the XCode command line tools in qt. Sorry, I'm new at Qt.

    Here are some pictures of what I am seeing.

    https://docs.google.com/file/d/0B4ZBg2H33Su2d1hBaVhmLTdWdWc/edit?usp=sharing

    https://docs.google.com/file/d/0B4ZBg2H33Su2ZFMyeEtmY3pKMnM/edit?usp=sharing



  • Open XCode, then XCode->Preferences and check you have command line tools installed, else install.



  • XCode shows that I have the command line tools installed. Yet when I go and look at /usr/bin/ and gdb doesn't exist.

    I found /usr/bin/lldb, created a clone of an existing qt kit in Qt preferences and set the debugger to the LLDB engine and selected this executable. I restarted Qt and created a new project using this kit, yet it still says that there is no debugger set up.



  • I am in front of the same issue OS X.8, XCode 5, the command line tools shown to be installed and using QT 5.1 ...

    i compiled my project fine and can run, but when trying in debug mode ... got no debugger setup

    not sure what i can do... thank you for your help



  • Did anyone ever resolve this ? I am having the exact same issue, and without the ability to debug, I am dead in the water right now.

    Any help would be appreciated.



  • i was able to solved it... by setting in Preferences/buildRun Kits tab the debugger to /usr/bin/lldb



  • Thanks, for responding.

    I tried that, and it looked promising.

    But when I try to debug (one of the examples) I get a message saying:

    'the gdb process terminated unexpectedly (code 0)"



  • I don't even get that far. I have lldb installed, just installed the dev tools for mavericks, no gdb, though. Still get the "No debugger set up" dialog. Did a clean on the projects, restart computer, can use lldb from the command line, but not from Qt. Any ideas appreciated.



  • Disclaimer: I've been trying to use Qt for only about a week, so I'm not a Qt expert or anything.

    I'm still running Mountain Lion, but I've installed Qt 5.2 (beta) which comes with Qt Creator 3.0, and there seems to be better lldb support. I can run and debug, although I'm not sure about the limitations of debugging using lldb because I'm still very new to Qt as a whole. I normally wouldn't run a beta being this new to something, but it's the only option available that I can debug with.

    However, I did install XCode 5, and from its options the 'Command Line Tools' before installing 5.2, though.

    Just be wary of the tutorials because the designer doesn't work for some of them that I tried because they use QtQuick 2 components and there is no support for QtQuick 2 in the Design mode, so you're going to be stuck with editing QML through the editor. It has something to do with the way qml2puppet (required for Designer) was packaged with the Mac OSX distribution incorrectly.

    If anyone can help on that issue, I would appreciate it. A Lot.

    I am intrigued by Qt, and I hope I get a better understanding because it seems like a very powerful tool. However, it does take a little bit of head banging to get the environment set up. Like I said, I'm only into it about a week so I am by no means an authority on any of this. I'm learning, just like you.

    I hope that helps.



  • Hi all,
    same problem here, with Mavericks, Qt 5.1.1. Even if I clone the Kit, and select /usr/bin/lldb as debugger, the same error shows up.

    Any ideas?



  • It seems that LLDB will be better supported in next releases: http://blog.qt.digia.com/blog/2013/11/12/qt-creator-and-lldb/



  • Using Qt 5.2.1 on OS 10.8.5 I was getting the same error. To resolve it I was able to clone the clang Kit and select the lldb debugger. lldb seems to be working now.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.