Error when build qwt with qt 5.1.1(mingw48)



  • Environment:
    Windows7 64bit
    Qt: qt-windows-opensource-5.1.1-mingw48_opengl-x86-offline.exe
    install to C:\Qt\Qt5.1.1
    qwt: qwt-6.1.0.zip (http://sourceforge.net/projects/qwt/files/qwt/6.1.0/qwt-6.1.0.zip/download)
    install to C:\qwt-6.1.0

    instruction followed: http://qwt.sourceforge.net/qwtinstall.html

    issue:
    I have try sometimes to build the qwt, build it always give me a failed result, show that some library could not be found,
    WHILE I can find them in Qt install directory, for example
    Qt5OpenGL.dll exist in @C:\Qt\Qt5.1.1\5.1.1\mingw48_32\bin@

    and the same with Qt5Svg.dll, Qt5PrintSupport.dll, Qt5Widgets.dll, Qt5Concurrent.dll, Qt5Gui.dll, Qt5Core.dll

    the compile output message is shown as below
    @
    compiling moc/moc_qwt_thermo.cpp
    moc qwt_wheel.h
    compiling moc/moc_qwt_wheel.cpp
    linking ../lib/qwt.dll
    c:/qt/qt5.1.1/tools/mingw48_32/bin/../lib/gcc/i686-w64-mingw32/4.8.0/../../../../i686-w64-mingw32/bin/ld.exe: cannot find -lQt5OpenGL
    c:/qt/qt5.1.1/tools/mingw48_32/bin/../lib/gcc/i686-w64-mingw32/4.8.0/../../../../i686-w64-mingw32/bin/ld.exe: cannot find -lQt5Svg
    c:/qt/qt5.1.1/tools/mingw48_32/bin/../lib/gcc/i686-w64-mingw32/4.8.0/../../../../i686-w64-mingw32/bin/ld.exe: cannot find -lQt5PrintSupport
    c:/qt/qt5.1.1/tools/mingw48_32/bin/../lib/gcc/i686-w64-mingw32/4.8.0/../../../../i686-w64-mingw32/bin/ld.exe: cannot find -lQt5Widgets
    c:/qt/qt5.1.1/tools/mingw48_32/bin/../lib/gcc/i686-w64-mingw32/4.8.0/../../../../i686-w64-mingw32/bin/ld.exe: cannot find -lQt5Concurrent
    c:/qt/qt5.1.1/tools/mingw48_32/bin/../lib/gcc/i686-w64-mingw32/4.8.0/../../../../i686-w64-mingw32/bin/ld.exe: cannot find -lQt5Gui
    c:/qt/qt5.1.1/tools/mingw48_32/bin/../lib/gcc/i686-w64-mingw32/4.8.0/../../../../i686-w64-mingw32/bin/ld.exe: cannot find -lQt5Core
    collect2.exe: error: ld returned 1 exit status
    Makefile.Release:320: recipe for target '../lib/qwt.dll' failed
    mingw32-make[2]: *** [../lib/qwt.dll] Error 1
    mingw32-make[2]: Leaving directory 'c:/qwt-6.1.0/src'
    Makefile:38: recipe for target 'release-all' failed
    mingw32-make[1]: *** [release-all] Error 2
    mingw32-make[1]: Leaving directory 'c:/qwt-6.1.0/src'
    makefile:41: recipe for target 'sub-src-make_first-ordered' failed
    mingw32-make: *** [sub-src-make_first-ordered] Error 2
    10:22:44: The process "C:\Qt\Qt5.1.1\Tools\mingw48_32\bin\mingw32-make.exe" exited with code 2.
    Error while building/deploying project qwt (kit: Desktop Qt 5.1.1 MinGW 32bit)
    When executing step 'Make'
    10:22:44: Elapsed time: 11:30.
    @

    [moved to 3rd party Software, koahnig]



  • Please check whether you have the right to set the environment variable



  • Which environment variable?
    would you please show some details? Thank you.



  • Hi cokefish,

    Creating a system environment called LIBRARY_PATH and setting it to C:\Qt\5.1.1\mingw48_32\bin solved the problem for me.

    On your system, you may have to set the LIBRARY_PATH environment variable to C:\Qt\Qt5.1.1\5.1.1\mingw48_32\bin



  • [quote author="SurlyDuff" date="1380686616"]Hi cokefish,

    Creating a system environment called LIBRARY_PATH and setting it to C:\Qt\5.1.1\mingw48_32\bin solved the problem for me.

    On your system, you may have to set the LIBRARY_PATH environment variable to C:\Qt\Qt5.1.1\5.1.1\mingw48_32\bin[/quote]

    solved it for me too, thank you!

    I have another question. Before trying setting the LIBRARY_PATH variable I've added LIBS += -L"QTLIBDIR..." in the qwt.pro file. Why didn't this work ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.