[Solved]Problem with QT 5.1.1 GCC_64 on Xubuntu 12.04.



  • Hello devnet,
    I'm a noob and please be understanding.
    I install Qt 5.1.1 for Linux 64-bit (415 MB) and ruuning QT creator, but compiler is not automaticaly detected. How to manualy configure, becouse i don't see it on /QT folder?
    Sorry my engilsh:)



  • Hi,

    On linux, you have to install the compiler yourselves, its not in the Qt directory.

    For GCC compiler:
    @sudo apt-get install gcc g++ make @

    For Clang compiler:
    @sudo apt-get install clang make @

    after this Qt should detect your compilers, with GCC as default.

    if not, you can add the compiler manually:

    • preferences -> Build & Run -> Compilers
    • Add -> (GCC or Clang) -> Compiler path =
      /usr/bin/g++ (if GCC)
      /usr/bin/clang++ (if Clang)


  • It's working! Thank you very much :)



  • Perfect!

    Do you mark this post as [solved] in the title,

    Regards,


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.