[SOLVED]noob: can't debug



  • I'm importing xTuple.pro (and the associated files) into QT 5.1 Qt Creator on Linux. I got it to compile and it runs very well. The problem is I can't debug anything. I set a breakpoint and it does not stop.

    &"warning: GDB: Failed to set controlling terminal: Inappropriate ioctl for device\n"
    Is all I get in the output.

    But I can debug the examples. So does anyone have a suggestion as to what is happening here?????

    Johnf


  • Moderators

    You need to compile your project in debug mode, then run with debugger in Qt Creator.



  • This maybe a duh question: How do I force the QT Creator 2.8.1 to build a "debug mode". It makes sense what you say but I don't what I need to do to cause the debug build.



  • I solved the problem - thanks.

    Since this was a project I imported and there were a few CONFIG statements that may have prevented the debug.

    So I removed all the statements and did a qmake and build.

    I works now.



  • I also got same kind of error (&“warning: GDB: Failed to set controlling terminal: Inappropriate ioctl for device\n”), but, Here I findout error place, that was an Array index, i.e, I created a list of array of [10] numbers and error occured in first index of array. i.e, Array[0] values.. How can I solve this?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.