Qt5 WebKit not displaying fonts when compiled on Ubuntu Server



  • I have a Qt5 webkit instance running to make screenshots of webpages on a server. The Qt5 version is replacing a fully functional Qt4 server that leaked memory and had threading issues.

    The Qt5 webkit instance works when compiled on Ubuntu 13.04 desktop, however on the same server where the Qt4 version worked, the Qt5 version renders no fonts at all, not even custom css fonts from the webpage being displayed.

    Any ideas if this is a compile flag, a Qt setting somewhere, or ubuntu packages I need to install? I am using the same version of Ubuntu's package-managed Qt5 on both systems.

    Here is a screenshot comparing the rendering
    http://cl.ly/image/2F3f3b3r1S1I

    I'm getting a lot of this message:

    bq. QFontDatabase: Cannot find font directory '/usr/lib/x86_64-linux-gnu/fonts' - is Qt installed correctly?

    However on ubuntu it shouldn't be looking there for fonts, but in the system-wide fonts folder.



  • Update:

    I am running in a headless environment without X11 or XVFB.

    I see a few examples of this around the internet with QT apps, and fonts appear to work in those situations.

    I symlinked the /usr/share/fonts directory to the /usr/lib/x86_64-linux-gnu/fonts and solved the warning in my first post.

    I've also run

    bq. sudo fc-cache -f -v

    before building to make sure it picks up the fonts for fontconfig.

    However I'm still having no luck with getting fonts to render.

    I have a new message displayed once when rendering:

    bq. This plugin does not support font engines created directly from font data

    Anyone have any ideas what I can try next?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.