Important: Please read the Qt Code of Conduct -

SOLVED Problems with a project in design view breaking

  • Hey guys,

    First post! I'm trying to get comfortable with Qt Creator by running through the tutorials. The first tutorial is fine, the program compiles and exits with error code 0. But now I'm onto the second tutorial and I'm running into an interesting problem:

    I add the icon to my canvas and change the location (this being done in the design tab). Then when I go to change the ID to "icon" as instructed everything seems to break. The background color I set on my parent rectangle disappears and the box in the canvas turns white. Also my image that I dragged onto the canvas turns into a blue dot.

    After a few tries it seemed to be caused by changing the ID, so I decided to just leave the ID as it was set by default. But then a few steps later I found that switching between the edit and the design tab (to see the tutorial but making NO changes) caused the design tab view of my project to "break" once again. The rectangle goes from the grey background to white, and the image disappears with a blue dot in it's stead. None of the code changes and the values are all still set in the design tab 'correctly'

    I'm guessing this problem is most likely system related, but I was wondering if anyone had any thoughts as to things I might be able to try.

    Qt Creator 2.7.2, VS2010Pro



  • Moderators


    • Which tutorial is this? (There are many)
    • Which version of Qt do you have? (Qt Creator is just an IDE -- it is separate from the Qt libraries themselves)
    • Which version of Windows are you running?

  • Hey JKSH,

    1. Creating a Qt Quick
    2. Qt 5.1.0 (x86)
    3. Win7Pro

  • Moderators

    I just realized it could be a bug with the Qt Quick Designer (which is part of Qt Creator).

    Qt Creator 2.8.1 has just been released along with Qt 5.1.1 (see "here": and "here": Try updating your SDK, and see if that fixes the problem for you. Updating also gives you the latest features and bugfixes.

  • Yeah that seemed to solve my problem, thanks for the help JKSH.

    Also the following bug report popped up after setting my kit to 5.1.1. As described in the bug, restarting Qt Creator solved the issue.

  • Moderators

    Glad to hear :) Happy coding!

Log in to reply