Qt5 vc12 64 build with webkit giving unresolved for WebKit::WebProcessMainQt



  • Evening all,

    when building Qt 5.1 with webkit on windows using vc 2012 I keep getting the following unresolved.
    if I skip over building QtWebProcess.exe then it continues and builds fine

    does anyone have any idea what the cause of this could be?

    configure:
    configure -static -release -opensource -openssl -icu -prefix C:\Development\Qt
    @MainQt.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) int __cdecl WebKit::WebProcessMainQt(class QGuiApplication *)" (_imp?WebProcessMainQt@WebKit@@YAHPEAVQGuiApplication@@@Z) referenced in function main
    MainQt.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) void __cdecl WebKit::initializeWebKitWidgets(void)" (_imp?initializeWebKitWidgets@WebKit@@YAXXZ) referenced in function main
    ....\bin\QtWebProcess.exe : fatal error LNK1120: 2 unresolved externals
    jom: C:\Development\Qt\src\qtwebkit\Source\WebKit2\Makefile.WebProcess.Release [
    ....\bin\QtWebProcess.exe] Error 1120
    jom: C:\Development\Qt\src\qtwebkit\Source\WebKit2\Makefile.WebProcess [release]
    Error 2
    jom: C:\Development\Qt\src\qtwebkit\Source\Makefile.QtWebKit [sub-WebKit2-WebPro
    cess-pro-make_first-ordered] Error 2
    jom: C:\Development\Qt\src\qtwebkit\Makefile [sub-Source-QtWebKit-pro-make_first
    -ordered] Error 2
    jom: C:\Development\Qt\src\Makefile [module-qtwebkit-make_first] Error 2@



  • I have the exact same error. I noticed that the static release build of WebProcessMainQt exports the missing symbol, whereas the debug build does not. The same thing goes for InitWebKitQt.lib.

    I do not understand why building release or debug should influence if a symbol is exported or not. This is very odd. I looked through the .pro files and generated Makefiles and could not find any clue.



  • do you resolved the error?
    i have the same error.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.