Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Can't Deploy from OSX 10.8 for 10.6



  • I tried to compile an application for osx .6 snow leopard, but it simply doesn't work. I don't get it why, even with a simple Hello World test App. running on 10.8 works fine.

    I builded Qt5 with my own configure :
    @./configure -developer-build -opensource -nomake examples -nomake tests -confirm-license -qt-sql-mysql@

    to add mysql support and works fine in 10.8

    I compile via Qt Creator with these parameters :
    @qmake LSPRO.pro -r -spec macx-clang CONFIG+=release CONFIG+=x86_64@

    In my PRO file I have these elements:
    @TEMPLATE = app
    HEADERS =
    mainwindow.h
    app_mediamanager.h
    api.h
    tool_htmleditor.h
    tool_videoencoder.h
    tool_thumbnaileditor.h
    SOURCES =
    main.cpp
    mainwindow.cpp
    app_mediamanager.cpp
    api.cpp
    tool_htmleditor.cpp
    tool_videoencoder.cpp
    tool_thumbnaileditor.cpp

    QT += network webkitwidgets widgets concurrent sql

    QMAKE_CXXFLAGS_X86_64 += -mmacosx-version-min=10.6
    QMAKE_MACOSX_DEPLOYMENT_TARGET = 10.6

    ICON = icon.icns

    RESOURCES = lspro.qrc@

    I add the libraries with macdeployqt script. When running on 10.6 I get this as error in the report:

    @Dyld Error Message:
    Library not loaded: /usr/lib/libc++.1.dylib
    Referenced from: /Users/username/Desktop/LSPRO.app/Contents/MacOS/../Frameworks/QtWebKitWidgets.framework/Versions/5/QtWebKitWidgets
    Reason: image not found@

    The problem surely lies between my screen and my chair, but I don't get it...
    Thanks for reading me!



  • I'm apparently getting the same error, as some of my paying customers have reported. I was thinking that it might have something to do with the fact that prior to Qt 5 I was deploying a 32/64 bit universal binary, but with qt 5 I only get a 64 bit binary. This would explain it if libc++.1.dylib in 10.6 is 32 bit only, but I really don't know. Of course, if my program was running in 64 bit mode under 10.6 anyway, then this couldn't be the case. I'll see what I can do for testing, and let you know if I figure something out. Of course, if anyone else already knows the answer, I'm sure we'd both appreciate the solution...



  • Ok, scratch that last. On further thought, the 32/64 bit issue couldn't possibly be the case, for a number of reasons. Sorry, temporary senility moment, I guess :P

    Further research returns this bug report: https://bugreports.qt-project.org/browse/QTBUG-30487 Which, if you follow through the comments, seems to indicate that passing -no-c+11 to the configure command should do the trick. I'll be trying that later


Log in to reply