Building Qt4.8.x on Lion with xcode 4.6 or higher



  • Can I build Qt 4.8.x on OSX 10.7.x using XCode 4.6.x and Deploy the application on osx 10.6.x 10.7.x 10.8.x i.e. on Snow Leopard, Lion and Mountain Lion?

    I am trying since several days but no result I even tried to explicitly specify -sdk ..10.6.sdk after giving aias Developer/Sdk/... But having very tough time.

    Webkit complains it cannot find symbol " _kCFWebServicesProviderDefaultDisplayNameKey" that is referenced from QtWebKit.

    I see on Qt's bug site that few people says they were able to do it by using sdk 10.6.sdk using lower xcode, but I dont understand why I do need to use 10.6

    technically the SDK shouldn't matter, as long as "-mmacosx-version-min=10.6" is set as deployment target.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.