Qmake can't find wayland-egl( building QtWayland )



  • when I run qmake, I get next log:

    /home/user/Qt5.1.0/5.1.0/gcc/bin/qmake
    Info: creating cache file /home/user/qtwayland/.qmake.cache
    Checking for wayland... yes
    Checking for xkbcommon... yes
    Checking for wayland_scanner... yes
    Checking for wayland_egl... no
    Checking for egl... no
    Checking for brcm_egl... no
    Checking for glx... yes
    Checking for xcomposite... yes
    Project MESSAGE: no wayland-egl support detected, cross-toolkit compatibility disabled

    I build QtWayland by http://qt-project.org/wiki/QtWayland
    So, why qmake can't find wayland-egl and egl?



  • i have the same issue i can't get qtwayland to work either



  • [quote author="jrch2k10" date="1374593326"]i have the same issue i can't get qtwayland to work either [/quote]

    Did you compile MESA?



  • well it failed me in Arch and Gentoo with mesa git and wayland 1.2



  • Looks like "#480654":https://bugs.gentoo.org/show_bug.cgi?id=480654 is the reason.



  • the reason is that your qt base is not compiled with egl support

    in order to do this you have to make sure that options "-egl" and "-opengl es2" are used when running configure.

    Example:

    ./configure -confirm-license -opensource -egl -opengl es2

    make



  • Hi,

    I am getting error

    ./configure -top-level -release -opengl es2 -device linux-rasp-pi3-g++ -device-option CROSS_COMPILE=/usr/bin/arm-linux-gnueabihf-'' -sysroot /home/fs/raspi/sysroot -opensource -confirm-license -make libs -prefix usr/local/qt5pi -extprefix /home/fs/raspi/qt5pi -hostprefix /home/fs/raspi/qt5 -v

    Note: No wayland-egl support detected. Cross-toolkit compatibility disabled.

    ERROR: Feature 'egl' was enabled, but the pre-condition '(features.opengl || features.openvg) && (features.angle || libs.egl)' failed.

    ERROR: The OpenGL functionality tests failed!
    You might need to modify the include and library search paths by editing QMAKE_INCDIR_OPENGL[_ES2],
    QMAKE_LIBDIR_OPENGL[_ES2] and QMAKE_LIBS_OPENGL[_ES2] in the mkspec for your platform.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.