QT Creator 2.8 doesn't build with Qt5.1

  • Hello,
    I downloaded the QtCreator 2.8 sources and wanted to build them for Qt 5.1.

    However, at the end, the linking fails with "cannot find -lqbscore". A google search yields 3 results, and only one of these seems to be related to the problem but it's the paste of a russian irc chat.

    So I guess the problem must be from my configuration, but I don't know where to look !

    ps: I am running "Qt 5.1.0 for Windows 32-bit (MinGW 4.8, OpenGL, 666 MB) (Info)"

    Edit: problem seems to originate from qbsprojectmanager, here is a paste of the make output :

  • Moderators

    Try checking out QBS together with Qt Creator ("more info":http://qt-project.org/doc/qtcreator-2.8/creator-project-qbs.html).

  • Okay, I don't have use for this so I disabled it by modifying the plugins.pro file.
    Now it builds, but when running QtCreator I have the following error :
    The entry point in the procedure InterlockedCompareExchange@12 cannot be found in the dynamic link library qtcreator.exe

    (The original error message is in french so I tried translating it according to my technical knowledge, but I can't be sure 100% that it would be the same in english).

    Edit: thanks to some obscure blog ( http://kaskavalci.com/ ), I solved it by moving the position of ..\Qt5.1.0\5.1.0\mingw48_32\bin in my path... seriously, WTF ? XD

Log in to reply