Debug doesn't work : inferior stopped, unknown signal



  • Hello everyone!

    I'm French (so I'm sorry if my English is not perfect, I'll do my best!), I discovered Qt few months ago and now I love it :)
    I have a problem using the debugger with Qt Creator: I create a simple Qt GUI application, I compile and I launch it very well, but if I launch it with the debugger, I receive that: "The inferior stopped because it received a signal from the operating system. signal name:? signal meaning: Unknown signal." and Qt Creator shows me a dump of assembler code for function "ntdll!LdrAlternateResourcesEnabled"; apparently the problem come from the ntdll.dll library.
    I tried to use GDB directly with the Qt Command Prompt, same result! I searched on Internet but I didn't find the same problem (some people had a "segmentation fault" issue, but it's not my case).

    Thank you very much for your help!
    Alex.



  • How OS, Qt, GDB, Compiler versions do you use?



  • Which OS in your PC ,?

    And which version of Qt ?
    Are you making application for mobile or desktop ?



  • Thank you for your answers, I'm sorry I didn't specify this details:
    My OS is Windows XP (SP2)
    I use Qt 4.7.0 (32 bits) (2010.05)
    The version of Qt Creator is 2.0.1
    About GDB:

    • In the Qt Creator configuration dialog, the version of GDB is 7.1.0.20100329-cvs (the corresponding file is [Qt Directory]\pythongdb\gdb-i686-pc-mingw32.exe)
    • When I use the Qt Command Prompt and I type "gdb", the version is 6.8 (I think the corresponding file is [Qt Directory]\mingw\bin\gdb.exe)
      Anyway, I get the problem in both versions.
      And I am not making application for mobile.

    Thank you again!



  • Heard about similar problems with some security systems installed (like komodo), maybe it your case too?


  • Moderators

    If you want the developers to look at this then please file a "bugreport":http://bugreports.qt.nokia.com/.

    If you do so, then make sure to include the full debugger output (shown in the top right part of the debug mode). Without that information it is almost impossible to tell what is going wrong.



  • Yes, I also heard about security systems wich could be the problem, so I tried to debug after deactivated my firewall (Kerio) and the anti-virus guard (AntiVir)... but still doesn't work :(

    I'll go on bugreports.qt.nokia.com, thanks for the advice !



  • There are gdb 7.2 builds at ftp://ftp.qt.nokia.com/misc/gdb/7.2/

    Maybe using them makes a difference.



  • AlexV, try to deactivate all your security systems, reboot and after it try debug again. Not sure that it will help, but at least you will know that problem is not in your security systems.



  • AlexV, I have the same problem. Have you solved this problem? If you did, can you please post here the solution? Thanks in advance.
    alepana



  • Hello alepana, sorry for the delay of my answer, I still don't resolve my problem, I'm following the issue on Qt bugreport. As soon as I have new informations I will post an explanation here (and you can do the same if you find a solution before me :) !)

    Alex.



  • @AlexV I find the solution on the avira site. The problem was a bug after updating the avira antivirus. This is the site where I find the solution: http://www.avira.com/en/support-for-business-knowledgebase-detail/kbid/805. You just follow those instructions and you can resolve the problem! Sorry for my english ...
    Alepana



  • Awesome!!!!!!!!!!!!!!!!! I can't believe that, it worked!!!!!!!!!!!!!! Thank you very much Alepana :)
    Thank you again!
    And your English is perfect;)
    Alex.



  • disable reverse debugging and you're gonna be ok


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.