"xllextras module not found" error when compiling qt-creator-2.8.0



  • I seem to have successfully compiled qt-everywhere-opensource-src-5.1.0 on my employer's workstation (running RHEL5), but am having problems with qt-creator-2.8.0.

    I say that I "seem" to have successfully compiled qt-everywhere, because after the compilation ran to completion with no errors (after a bit of work), there was no binary named "designer" in the "....qtbase/bin" directory. This differs from when I successfully compiled qt-everywhere-opensource-src-5.0.2 a couple of weeks ago, along with qt-creator-2.7.1. I know this worked because it ran ok, and I was able to test some tutorials.

    Given the above, when in the "qt-creator-2.8.0.src" directory I execute "<path-to-qmake>/qmake -r", I get a few lines like "Reading ..." and then this error:

    "Project WARNING: xllextras module not found, raising the main window might not work. (The xllextras module is part of Qt 5.1 and later.)
    Project ERROR: Unknown module(s) in QT: script"

    Any clues about what's going on?

    I can't find any references to "xllextras" by googling, so I'm stuck.


  • Moderators

    The missing "designer" binary suggests a broken compilation.

    You said "the compilation ran to completion with no errors (after a bit of work)"... what work was that? (it should've been straightforward -- if you had to do extra hacks, it sounds like something went wrong)

    Try cleaning your build tree, re-configuring and re-compiling.

    If that still doesn't work, please post your configure options and configure output.

    It's X11 (x-one-one) by the way.



  • The "bit of work" involved disabling openssl compilation.

    I decided to start from scratch so as to reproduce the problems I saw.
    "From scratch" means removing the source directories and untarring again.
    Here's what I got:

    First try for qt-everywhere:

    ./configure -prefix $PWD/qtbase -opensource -nomake tests -confirm-license
    gmake

    This resulted in some errors:

    #############
    g++ -c -include .pch/release-shared/Qt5Network -pipe -O2 -fvisibility=hidden -fvisibility-inlines-hidden -fno-exceptions -Wall -W -D_REENTRANT -fPIC -DQT_NO_LIBUDEV -DQT_NO_XCB -DQT_NO_XKBCOMMON -DQT_NO_USING_NAMESPACE -DQT_BUILD_NETWORK_LIB -DQT_BUILDING_QT -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_DEPRECATED_WARNINGS -DQT_DISABLE_DEPRECATED_BEFORE=0x050000 -DQT_NO_EXCEPTIONS -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_CORE_LIB -I../../mkspecs/linux-g++ -I. -I../../include -I../../include/QtNetwork -I../../include/QtNetwork/5.1.0 -I../../include/QtNetwork/5.1.0/QtNetwork -Ikernel -I../../include/QtCore -I../../include/QtCore/5.1.0 -I../../include/QtCore/5.1.0/QtCore -I.moc/release-shared -o .obj/release-shared/qsslsocket_openssl.o ssl/qsslsocket_openssl.cpp
    ../../include/QtCore/../../src/corelib/tools/qsharedpointer_impl.h: In instantiation of ‘QSharedPointer<QSslContext>’:
    ssl/qsslsocket_p.h:119: instantiated from here
    ../../include/QtCore/../../src/corelib/tools/qsharedpointer_impl.h:500: warning: lowering visibility of ‘QSharedPointer<X> QtSharedPointer::copyAndSetPointer(X*, const QSharedPointer<Y>&) [with X = X, Y = Y, T = QSslContext]’ to match its type
    ssl/qsslsocket_openssl.cpp: In member function ‘virtual void QSslSocketBackendPrivate::continueHandshake()’:
    ssl/qsslsocket_openssl.cpp:1414: error: ‘q_SSL_ctrl’ was not declared in this scope
    gmake[3]: *** [.obj/release-shared/qsslsocket_openssl.o] Error 1
    gmake[3]: Leaving directory /home/afbacher/QT/qt-everywhere-opensource-src-5.1.0/qtbase/src/network' gmake[2]: *** [sub-network-make_first] Error 2 gmake[2]: Leaving directory/home/afbacher/QT/qt-everywhere-opensource-src-5.1.0/qtbase/src'
    gmake[1]: *** [sub-src-make_first] Error 2
    gmake[1]: Leaving directory `/home/afbacher/QT/qt-everywhere-opensource-src-5.1.0/qtbase'
    gmake: *** [module-qtbase-make_first] Error 2
    #############

    Reconfigure and compile with -no-openssl flag:

    cd ~/QT/qt-everywhere-opensource-src-5.1.0/qtbase
    gmake confclean
    cd ..
    ./configure -prefix $PWD/qtbase -opensource -nomake tests -confirm-license -no-openssl
    gmake

    Continued in next post.



  • Here's the last bit of output from configure:

    #############
    Configure summary

    Build type: linux-g++ (x86_64, CPU features: mmx sse sse2)
    Platform notes:

            - Also available for Linux: linux-kcc linux-icc linux-cxx
    

    Build options:
    Configuration .......... accessibility audio-backend clock-gettime clock-monotonic compile_examples concurrent evdev fontconfig full-config getaddrinfo getifaddrs iconv inotify ipv6ifname large-config largefile linuxfb medium-config minimal-config mremap nis opengl pcre png precompile_header qpa qpa reduce_exports release rpath shared small-config sse2 sse3 ssse3 system-freetype system-jpeg system-png system-zlib v8 v8snapshot xlib xrender
    Build parts ............ libs tools examples
    Mode ................... release
    Using C++11 ............ no
    Using PCH .............. yes
    Target compiler supports:
    SSE2/SSE3/SSSE3 ...... yes/yes/yes
    SSE4.1/SSE4.2 ........ no/no
    AVX/AVX2 ............. no/no

    Qt modules and options:
    Qt D-Bus ............... no
    Qt Concurrent .......... yes
    Qt GUI ................. yes
    Qt Widgets ............. yes
    JavaScriptCore JIT ..... yes (To be decided by JavaScriptCore)
    QML debugging .......... yes
    Use system proxies ..... no

    Support enabled for:
    Accessibility .......... yes
    ALSA ................... no
    CUPS ................... no
    FontConfig ............. yes
    Iconv .................. yes
    ICU .................... no
    Image formats:
    GIF .................. yes (plugin, using system library)
    JPEG ................. yes (plugin, using system library)
    PNG .................. yes (in QtGui, using system library)
    Glib ................... no
    GStreamer .............. no
    GTK theme .............. no
    Large File ............. yes
    libudev ................ no
    Networking:
    getaddrinfo .......... yes
    getifaddrs ........... yes
    IPv6 ifname .......... yes
    OpenSSL .............. no
    NIS .................... yes
    OpenGL ................. desktop
    OpenVG ................. no
    PCRE ................... yes (bundled copy)
    pkg-config ............. yes
    PulseAudio ............. no
    QPA backends:
    DirectFB ............. no
    EGLFS ................ no
    KMS .................. no
    LinuxFB .............. yes
    XCB .................. no
    Session management ..... yes
    SQL drivers:
    DB2 .................. no
    InterBase ............ no
    MySQL ................ yes (plugin)
    OCI .................. no
    ODBC ................. no
    PostgreSQL ........... no
    SQLite 2 ............. no
    SQLite ............... yes (plugin, using bundled copy)
    TDS .................. no
    udev ................... no
    xkbcommon .............. no
    zlib ................... yes (system library)

    Qt is now configured for building. Just run 'gmake'.
    Once everything is built, Qt is installed.
    You should not run 'gmake install'.
    #############

    This time I ended up with "designer" in the bin directory, so I went on to compile qt-creator:

    cd qt-creator-2.8.0-src
    /home/afbacher/QT/qt-everywhere-opensource-src-5.1.0/qtbase/bin/qmake -r
    make

    This resulted in some errors:
    #############
    /home/afbacher/QT/qt-everywhere-opensource-src-5.1.0/qtbase/include/QtCore/../../src/corelib/tools/qlist.h:761: instantiated from ‘void QList<T>::dealloc(QListData::Data*) [with T = QSharedPointer<const qbs::Internal::RuleArtifact>]’
    /home/afbacher/QT/qt-everywhere-opensource-src-5.1.0/qtbase/include/QtCore/../../src/corelib/tools/qlist.h:737: instantiated from ‘QList<T>::~QList() [with T = QSharedPointer<const qbs::Internal::RuleArtifact>]’
    ./language/language.h:255: instantiated from here
    /home/afbacher/QT/qt-everywhere-opensource-src-5.1.0/qtbase/include/QtCore/../../src/corelib/tools/qsharedpointer_impl.h:500: warning: lowering visibility of ‘QSharedPointer<X> QtSharedPointer::copyAndSetPointer(X*, const QSharedPointer<Y>&) [with X = X, Y = Y, T = const qbs::Internal::RuleArtifact]’ to match its type
    make[3]: *** [internaljobs.o] Error 1
    make[3]: Leaving directory /home/afbacher/QT/qt-creator-2.8.0-src/src/shared/qbs/src/lib' make[2]: *** [sub----shared-qbs-src-lib-make_first] Error 2 make[2]: Leaving directory/home/afbacher/QT/qt-creator-2.8.0-src/src/libs'
    make[1]: *** [sub-libs-make_first-ordered] Error 2
    make[1]: Leaving directory `/home/afbacher/QT/qt-creator-2.8.0-src/src'
    make: *** [sub-src-make_first-ordered] Error 2
    #############

    The fact that the first compile try without the -no-openssl flag
    produced errors containing some references similar to the failed
    compile with qt-creator -- namely, "QtSharedPointer" -- is
    suggestive to me of a common problem. Of course, I have no clue
    what that is.

    Suggestions?


  • Moderators

    Hmm... looks quite strange.

    Do you have OpenSSL libraries installed?

    Do you have another version of Qt in your environment? If so, that might be interfering with your build attempt.



  • [quote]Do you have OpenSSL libraries installed?[/quote]

    Yes. My sysadmin checked that. Also, a few weeks ago I sucessfully compiled qt-5.0.2, which I'm sure depends on OpenSSL.

    [quote]Do you have another version of Qt in your environment?[/quote]

    Yes, the 5.0.2 version. However, it's not installed in any standard locations, but only in the 5.0.2 directories. For example, "which qtcreator" and "which designer" don't find those binaries, since they're only in "....5.0.2....qtbase/bin".


  • Moderators

    I'm at a loss, sorry -- never seen this before.

    Try asking at IRC or the "Interest mailing list":http://lists.qt-project.org/mailman/listinfo/interest



  • I realise this is an old post, but for future reference, in case anybody runs into a similar issue, I found that the error results from using qmake from <yourQtSource>/qtbase/bin instead of /usr/local/YourQt/bin


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.