Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Updated from Qt4 to Qt5 -> QtCore4.dll is missing



  • Hey,

    i was using Qt4 for a while and now updated to using Qt5, but my application won't start, saying:

    "The program can't start because QtCore4.dll is missing from your computer. Try reinstalling the program to fix this problem."

    • I'm using the Qt5 Visual-Studio Add-In

    • my Qt-folder is located at C:\qt\5.0.2

    • in Visual-Studio Qt-Options: QT_5.0.2, C:\qt\5.0.2\qtbase

    • project's Qt-Version is QT_5.0.2

    • i added the user environment variable QT_DIR with key C:\qt\5.0.2

    • in project settings i added "additional include directories":

    $(QT_DIR)\qtbase\include\QtCore
    $(QT_DIR)\qtbase\include\QtGui
    $(QT_DIR)\qtbase\include\QtXml
    $(QT_DIR)\qtbase\include\QtOpenGL
    $(QT_DIR)\qtbase\include\QtWidgets
    and also $(QT_DIR)\qtbase\include

    • in project settings i added "additional library directories":

    $(QT_DIR)\qtbase\lib

    • in project settings i added "additional dependencies":

    Qt5Core.lib
    Qt5Gui.lib
    Qt5Xml.lib
    Qt5OpenGL.lib
    Qt5Test.lib
    Qt5Widgets.lib
    qtmain.lib
    Qt5PlatformSupport.lib

    I have no idea, why it still keeps asking for the QtCore4.dll. Can anybody help?


  • Moderators

    Did you:

    Clean your build tree, and

    Recompile your project?

    Uninstalling Qt 4 before doing that could also help



  • Here is my solution what worked for me so far: I opened up the Task Manager, clicked on "Start Up", and simply chose "disable Daemon". Since then I don't see this annoying pop-up message! :-)



  • Is it possible that in your application you are using some third party dll compiled with a previous version of Qt? Something like Qwt or Scintilla?

    My suggestion is using DependencyWalker (http://www.dependencywalker.com/). If you run it and load the compiled executable it should be rather easy to see where the Qt 4 core dll is referenced.

    • oops I see now that this is an old post :)

Log in to reply