Attaching Configuration of Jlink-JTAG with FriendlyARM Mini2440(ARM9) for debugging using QtCreator



  • Hi,

    I have Jlink-JTAG with serial no:058006790, and trying to connect to FriendlyARM Mini 2440.. using Qt creator....i have worked all the commands in the manuals but not succeded..required help..

                          My Initial configurations...on Board
    
    1. Setup up the GDBserver compiled for arm-linux and place in home folder of the board..

      1. Running the following commands from the folder

        [root@FriendlyARM gdbserver]# ./gdbserver :2331 /home/ggg (here ggg is the simple GUI program created in qtcreator and cross compile for arm-linux)

             Process /home/ggg created; pid = 712
             Listening on port 2331
        

    On Host Machine(UBUNTU 12.04)..

    1. Started ./StartJLinkGDBServer.sh ...JTAG Connected

    2. Started qtcreator with the same program running on the board,in release board..

    3. Then in tools->options->Debugger->GDB-> in GDB Startup Script placed the file "JLinkGDBServer.ini" provided by segger

    4. In qtcreator, Debug->Start Debugging->Start and Attach to remote application ..Settings as per required

    5. After presseing the ok buttion...the qt creator shows Debugging starts..

    6. But in the Jlink-GDBServer shows starting the CPU and then it holds on ...nothing happens

    7. If i press the Debug interrupt buttion in qtcreator the output of Jlink-GDB Server will close with Segmenation Fault

           ...What is the problem..is it with board or my settings..please suggest me ..worked more than a week to get upto hear....i want actually debug qt creator codes..please help me..waiting for your reply..pls provide any steps for correct excecution

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.