Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

SOLVED C++/QtQuick 2.0 Application doesn’t work on other computers



  • I know the rule of thumb is to copy all the DLLs and Resource files into the application directory.

    I build my application using QtQuick 2.0, Qt 5.0.2, Mingw47_32, QtCreator 2.7.0. I have finished developing the version 1, It compiles and runs completely fine, and now its time to deploy.

    I copied all the MingW compiled Qt DLLs (including QtGUI, QtCore, Qt5Qml.dll, Qt5Quick.dll, libGLESv2.dll, libEGL.dll, mingwm10.dll etc) and I also copied everything the way it is from C:\Qt\Qt5.0.2\5.0.2\mingw47_32\plugins to my Release Application directory. I copied my QML files into qml directory as well.

    It works perfectly fine on the Development machine.
    When I copy and paste exactly the same thing into a machine with no Qt there is no missing DLL error or funny requested the runtime to terminate error, but still doesn't work. It doesn't load my QML files. When I double click the EXE file, the size of the window-form is almost 0 by 0 pixel and when I expand it there is nothing inside.

    On my development machine If I rename the directory for my QML files I face the same sort of problem.

    On the deployment machine, where there is no Qt installed I created the same replica of the directory hierarchy. So Im sure it is not an absolute or a relative path issue.

    For some reason, In the Qt Creator, Under the Build menu Deploy option is grayed out.

    Im quite new to Qt, Did I miss any steps? I know Im almost there but just a tiny little thing is giving me a big Headache since yesterday morning.

    In the beginning I was too laid out, thinking it would be just a piece of cake now it is quite urgent, I have to fix it up by today evening.



  • It is solved,

    I just have to copy QtQuick.2 folder and its contents as well into my application directory.


Log in to reply