Creator Indexer broken?



  • Hi,

    I have a subdirectory project that I have created in the QtCreator 2.7.1 which contains 20 sub projects (including dll's and such)...

    Everything was working great in the creator for the past couple weeks, until today, I opened up my project and none of my ui elements are being recognized in the .cpp files.

    The weird thing is, everything still builds fine, but the auto completion does not work for all of the elements in my ui-> classes. Its like it is not updating its indexer.

    This came about when I updated some of the ui elements in one of the projects and all the sudden ALL of the ui elements in every project are not being recognized.

    I have tried recompiling, deleting all the of ui_.h files, and re running QMake, I have tried deleting all of the make files, and nothing seems to be working.

    Does anyone have any ideas?

    FYI: I do redirect my .moc and .ui files to a sub folder in a build folder which is all done in my .pri / .pro files

    Edit: Here's another interesting thing. My first sub project in my sub directory project is called 'core'. When I use the ui-> autocomplete functionality in the creator in any other subproject other than 'core' .cpp class that has a ui header included, the autocomplete points to the ui in the 'core' project. That is why I am not getting any references to my different ui's in my other subprojects... I have NO clue why all of my other projects ui files are pointing to that one mainwindow ui file in the 'core' project...And why the creator is not throwing errors on compile.


  • Moderators

    Pretty strange, but I'm experiencing the same thing right now, on 2 separate machines and Qt Creator 2.8 beta.



  • I will be trying to fix the issue today...It would be awesome if you could let me know if you find a solution!

    In a way, I am glad I am not the only one having this problem since I am going to be starting another large project very soon.



  • Sorry for the double, but I have a quick question slerdzio. Do you have multiple subprojects in your subdir project that contain a QMainWindow with the same name?

    I leave mine at the default mainWindow when creating the initial class in the project.


  • Moderators

    No, in the projects I'm working on, subprojects are either console apps or libraries. Actually, now that I think about it, none of the projects with subdirs template uses QMainWindow at all :) You can find them all on "github":https://github.com/sierdzio, if you feel like exploring.


  • Moderators

    Did somebody "file a bug report":https://bugreports.qt-project.org/ about this? Issues reported here tend to get lost.


  • Moderators

    No, for me it started happening with a git checkout (dev branch) so before reporting I would need to update QtC to a newer version and see if the problem persists.



  • Hi, the outcome was to change all of the MainWindow classes (in the sub projects) to their own unique name, and everything is now being recognized correctly.

    There still is something wrong with the indexer, since all of my MainWindow classes were encapsulated within their own projects and non were linked together. I don't think there should be any reason why the IDE should get confused with the MainWindow of a different project.

    I will file a bug report. Thank you!


  • Moderators

    Thnks go to you, too :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.