[SOLVED]Qt 5.0.2 Source Install



  • Hello! I have encountered a small problem when trying to install qt from sources...

    I have installed everything as recomended however I get this:

    NMAKE: Fatal error U1077: "C:\Program Files\dir to msvc2010\link.exe" : return code: '0x463'
    Stop.
    Could not find output file: No such file or directory


  • Moderators

    Does C:\Program Files\dir to msvc2010\link.exe exist?



  • yes yes... it exists i was just too lazy to write the whole thing... :) also link.exe is in that folder


  • Moderators

    Ah... silly me, you'll get a different error message if your linker isn't found :P

    Which instructions did you use?



  • configure -release -no-opengl



  • Read on stackoverflow that this error might be caused by examples so I excluded them with -nomake but still get the same error :( any help would be greatly appreciated :)


  • Moderators

    [quote]I have installed everything as recomended[/quote]When I said "Which instructions did you use?", I meant: "Which recommendation did you follow?" :)

    Also:

    • What version of Windows are you on?
    • Post more lines from your error message -- what file is it failing on?

    If you don't want to type messages out by hand, redirect the output to a log file:
    @
    configure [options] > confout.log 2> conferr.log
    @

    I'm not sure what's causing your problem, but I know that -no-opengl disables a large portion of Qt, so maybe something important went missing (which would mean there's a bug in the sources). Anyway, try removing -no-opengl -- it still won't use OpenGL, but it will use DirectX



  • ah... I tried to use from several instructions (OpenCV docs, Qt Docs and a small post on how to install for windows x64)... none of which worked... I am using Windows 7 x86 Proffessional. I've read somewhere that you must not have other Qt versions installed when compiling from sources... Or I missread I didn't got around to checking this yet. Now I am using another PC to try this out. Anywhom I get two errors depending if it is the first time running configure or not. Tried to add PATH variables and such... Nothing seems to work :(

    err:

    Microsoft (R) Program Maintenance Utility Version 10.00.30319.01
    Copyright (C) Microsoft Corporation. All rights reserved.

    NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 10.0\VC\BIN\link.EXE"' : return code '0x463'
    Stop.

    out:

    • C:/QtStatic/5.0.2/qtbase/configure -release -no-opengl -opensource

    This is the Qt for Windows Open Source Edition.

    You are licensed to use this software under the terms of
    the GNU Lesser General Public License (LGPL) version 2.1.

    Type 'L' to view the Lesser GNU General Public License version 2.1 (LGPLv2.1).
    Type 'y' to accept this license offer.
    Type 'n' to decline this license offer.

    Do you accept the terms of the license?
    Running syncqt...
    <srcbase> = C:/QtStatic/5.0.2/qtbase
    <outbase> = C:/QtStatic/5.0.2/qtbase
    Creating qmake...
    Running configuration tests...
    Could not find output file: No such file or directory
    *** qtbase/configure exited with non-zero status.



  • problem solved. On a fresh computer it is now runing nmake. I think it was because I had multiple Qt versions installed :) Thanks for the help


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.