QT Application on Linaro ubuntu Desktop for ZC702 ARM



  • Hi,
    I have created a QT application for ARM architecture by using Xilinx linux arm toolchain.
    So If I am checking the file type it is coming as it is built for ARM.
    But when I am executing it it is throwing an error as bash: ./App: No such File or Diretory but this file is present in the diretory from where i am executing it.

    What i have done on target is-

    1. Copied all the libraries and binary for ARM at /opt/Qt-arm__
    2. Configured the load path as export LD_LIBRARY_PATH=/opt/Qt-arm/lib

    So is there anything I am missing which is preventing me to run the application on the traget board.

    [[merged two identical threads, Tobias]]


  • Moderators

    "No such file or directory" can also mean "Wrong binary format or target architecutre". So do a quick check and run "file /Path/to/your/App" and make sure that it is indeed a executable file targetting arm with the correct wordwidth, etc.

    You can do that on your host.



  • Hi Tobias,
    I have checked the file type of executable in Host system as well as in Target so it is showing the file format and architecture as:
    32 bit elf file for ARM architecture...
    But still I am getting the same error as bash: ./App: No such File or Diretory

    Though the file is present in that folder and built for ARM Architecture.


  • Moderators

    What does ldd say? Are libraries missing?

    Try running the application in strace. Both tools need to run on the arm machine, so they may or may not be available.



  • Hi Tobias,
    I didnt get you. Whether strace is tool which I have to install onto my target board in order to run the application??

    And ldd I havent checked but In terms of library I have copied all the libraries at /opt/Qt-arm...
    And exported the LD Library path as well.



  • Hi,
    I have checked the ldd /Path/to/my/App so it is giving the message as:
    Not a dynamically executable

    Whereas If I am trying strace /Path/to/my/App it is not giving any log or error it is simply executing .

    So anything I am still missing..



  • Hi ,
    Now i am able to do ldd and getting log as

    libQtGui.so.4 => /usr/lib/arm-linux-gnueabihf/libQtGui.so.4 (0xb68aa000)
    libQtCore.so.4 => /usr/lib/arm-linux-gnueabihf/libQtCore.so.4 (0xb66ab000)
    libstdc++.so.6 => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6 (0xb6604000)
    libgcc_s.so.1 => /lib/arm-linux-gnueabihf/libgcc_s.so.1 (0xb65f3000)
    libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb650f000)
    libEGL.so.1 => /usr/lib/arm-linux-gnueabihf/mesa-egl/libEGL.so.1 (0xb64f4000)
    libfontconfig.so.1 => /usr/lib/arm-linux-gnueabihf/libfontconfig.so.1 (0xb64c8000)
    libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0xb64ad000)
    libaudio.so.2 => /usr/lib/arm-linux-gnueabihf/libaudio.so.2 (0xb6496000)
    libglib-2.0.so.0 => /lib/arm-linux-gnueabihf/libglib-2.0.so.0 (0xb63dc000)
    libpng12.so.0 => /lib/arm-linux-gnueabihf/libpng12.so.0 (0xb63bb000)
    libz.so.1 => /lib/arm-linux-gnueabihf/libz.so.1 (0xb63a2000)
    .....

    So all the libraryies are already present in my target as per the ldd output.

    But after that if i am executing the Apps its not showing any error as well its not firing up the GUI..

    So anyone have any idae so let me know



  • Hi All,

    We are trying to run a Qt application on Xilinx ZC-702 board(running linaro ubuntu desktop).

    We have followed below mentioned steps, but GUI is not firing..

    1. qt-everywhere-opensource-src-4.7.3.tar.gz(Extract It)

    2. qmake.conf: either replace the qmake.conf in /home/user/qt-everywhere-opensource-src-4.7.3/mkspecs/qws/linux-arm-gnueabi-g++/qmake.onf
      Replace: arm-none-linux-gnueabi-gcc by arm-linux-gnueabihf-gcc

    3. Set the path:
      export CROSS_COMPILE=arm-linux-gnueabihf-
      export PATH=/usr/bin:$PATH
      export ZYNQ_QT_BUILD=/home/user/qt-everywhere-opensource-src-4.7.3
      export ZYNQ_QT_INSTALL=/usr/local/Trolltech
      export PATH=$ZYNQ_QT_INSTALL/bin:$PATH

    4. ./configure -embedded armv7l -xplatform qws/linux-arm-gnueabi-g++ -little-endian -opensource -host-little-endian -confirm-license -prefix $ZYNQ_QT_INSTALL -qt-zlib -qt-libtiff -qt-libpng -qt-libmng -qt-libjpeg -no-openssl -no-nis -no-cups -iconv -no-pch -no-dbus -qt-freetype -no-opengl -qt-gfx-linuxfb -qt-gfx-vnc -qt-gfx-qvfb

    5. make
      make -install
      copied the libraries to the target board.

    6. ./appname -qws -display QVFb:0
      error: driver cannot connect
      Aborted

      ./appname -qws LinuxFb:mmwidth=1024:mmheight=768
      this dsnt give any error but, its not launching the GUI but printing the log messages in terminal.

    can you tell What steps are missing here?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.