Getting Error while opening QT creator in Centos6.2



  • hi
    few days back qt creator is installed its fine.

    Today while opening the QT creator from pannel It's not opened. then I tryied to open it from terminal its opened but in that It;s not showing GUI projects

    and In terminal I got an error like

    (<unknown>:3223): Gtk-WARNING **: Attempt to load unknown IM context type 'gtk-im-context-none'
    Warning: Kit file version 0 not supported, cannot restore kits!
    Qt version is no longer known, removing from kit "Desktop".
    Tool chain is no longer known, removing from kit "Desktop2".
    Qt version is no longer known, removing from kit "Desktop2".
    Tool chain is no longer known, removing from kit "Desktop2".
    Qt version is no longer known, removing from kit "Desktop".
    Qt version is no longer known, removing from kit "Desktop2".
    The X11 connection broke (error 1). Did the X11 server die?

    QXcbWindow: Unhandled client message: "_GTK_LOAD_ICONTHEMES"
    QXcbWindow: Unhandled client message: "_GTK_LOAD_ICONTHEMES"

    I am not getting what is this error?
    while searching in net also I am net understand what is this?

    what is this problem? Is there any file is missing?

    If any body knows reply me.

    Thanks in advance


  • Moderators

    Could you please check the .xml files found in ~/.config/QtProject/qtcreator Looks a bit like the profiles.xml is corrupted.

    If the files are not obviously wrong (e.g. truncated or empty), then "please file a bug report":https://bugreports.qt-project.org/ and attach the .xml files to it.



  • hi,
    I didn't find that folder. Are you saying about total sdk tool or qt-linux-opensource-5.0.2-x86-offline.run?

    I am having qt-linux-opensource-5.0.2-x86-offline.run which is downloaded from "QT-projecct-downloads":http://qt-project.org/downloads

    please explain me about this



  • hi, I got a doubt regarding this.

    From my first post, Is there any requirement of gtk or gnome like that?

    because now I can open the QT develeopment IDE, but while creating the project I am not getting GUI option. And I sea that in about plugins....
    qt creator is marked as 'X' means it is not installed. For this any dependencies required?

    plugin error is

    bq. Plugin initialization failed: Could not determine location of maintenance tool. Please check your installation if you did not enable this plugin manually.

    at terminal error like

    bq. (<unknown>:3223): Gtk-WARNING **: Attempt to load unknown IM context type ‘gtk-im-context-none’
    Warning: Kit file version 0 not supported, cannot restore kits!
    Qt version is no longer known, removing from kit “Desktop”.
    Tool chain is no longer known, removing from kit “Desktop2”.

    what is the exact meaning?

    while opening the project
    configure project option shows kit not found.



  • Today I found that the,
    to build Qt 5 system requirements are

    bq. You need git (>= 1.6.x) to get the packages.

    bq. To properly configure and build Qt 5 from source you also need Perl (>=5.14) and Python (>=2.6.x), as well as a working compiler.

    but in my system perl version is "perl-5.10.1-131.el6_4.i686"

    and I tried to install perl. while installing this

    yum install perl

    Package 4:perl-5.10.1-131.el6_4.i686 already installed and latest version

    lower version of perl is any problem to install QT?

    please reply me
    Thanks In advance



  • Finally Qt-creator is installed on Centos 6.4 It's working but it is giving a warning

    bq. (<unknown>:3223): Gtk-WARNING **: Attempt to load unknown IM context type ‘gtk-im-context-none’

    My problem was almost solved but only this one

    how can I solve this warning? why I am getting this warning


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.