Does QtBrowserPlugin on Internet Explorer still work?



  • Hi everyone,

    I have a question regarding the use of the QtBrowserPlugin from qt-solutions. If there's a more appropriate place to ask, please let me know, but for the time being I'll just post it here.

    When I build and install the 'trivial' example in Windows it works just fine in Firefox and Chrome (i.e. using the NPAPI interface) but not in Internet Explorer using the ActiveX interface. When I run Internet Explorer and surf to http://doc.qt.digia.com/solutions/4/qtbrowserplugin/qtbrowserplugin-example-trivial.html , I see [1] in which the area for the control is clearly indicated, but when I grant permission that area just disappears and nothing can be seen where the plugin should be.

    Now, a bit of logging revealed that the constructor of the widget was in fact executed, so I tried adding a 'show()' command to the constructor. In the Internet Explorer window this doesn't change a thing, but on the desktop this makes a white square area appear (see [2]). While this seems to indicate there's just something wrong with embedding the widget or with the parent handle, it's strange that that white area doesn't show the text that should be displayed.

    Now, I noticed that in the ActiveQt examples there's also a browser example that seems to load an Internet Explorer ActiveX control for the actual browsing. When I use this browser to go to the 'trivial' example page, the plugin is displayed correctly (see [3]). So it seems that at least in some circumstances the control can work correctly.

    Does anyone have an idea what could be going wrong here? And perhaps even how to fix it?

    Thanks,
    Jori

    [1] http://research.edm.uhasselt.be/~jori/trivial/trivial1.png
    [2] http://research.edm.uhasselt.be/~jori/trivial/trivial2.png
    [3] http://research.edm.uhasselt.be/~jori/trivial/trivial3.png


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.