Important: Please read the Qt Code of Conduct -

Windows Qt Deployment on Linux under wine (issue with UdpSocket connection)

  • Hi all,

    This may be more a "wine" topic, but I am hoping many people in Qt forums have tried similar things.

    I have built my project in windows XP sp3. I have a deployment that has the .exe and all the dlls it needs to run stand-alone on a windows PC.

    But now I want to run it on linux 10.10 under wine v1.4 I have a slight issue.

    When trying to bind to a UdpSocket (even on I get the following error message:

    @fixme:winsock:WSAIoctl WS_SIO_UDP_CONNRESET stub@

    Other then that everything else seems to work (xml, file access, logging, threads, etc...) and the program still continues to run.

    Does anyone know what this means or how I can fix it?

  • Moderators

    Looks like wine does not simulate loopback yet.

  • loopback?, I am not sure what you mean - is that something I can turn off from my project?

    I have tried with other external IP addresses. I also have another app (non-Qt) that uses windows UDP socket which works fine.


  • Moderators is the loopback address.

    Ok, so it seems to be more Qt-specific. Possibly a bug. I don't think Qt is being tested on Wine at all. Since you do have a Windows machine, better use that, or cross-compile from Linux.

  • Yeah, I could cross compile from linux :)

    But I just wanted to be able to run it on wine :(

Log in to reply