[Solved] Building qt from git - assembler error



  • Hello,
    I am trying to build qt5 from git following instructions from "here":http://qt-project.org/wiki/Building_Qt_5_from_Git. But it fails with following error on g++ ... schema/qxsdschemaparser_setup.cpp:
    @
    {standard input}: Assembler messages:
    {standard input}:23874: Warning: end of file not at end of a line; newline inserted
    {standard input}:24412: Error: bad register name %' {standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive g++: internal compiler error: Killed (program cc1plus) @ And on g++ ... schema/qxsdschematypesfactory.cpp: @ {standard input}: Assembler messages: {standard input}:40959: Warning: end of file not at end of a line; newline inserted {standard input}:41071: Error: no such instruction:_zn2v88interna'
    g++: internal compiler error: Killed (program cc1plus)
    @
    Here is output of g++ -v:
    @
    Using built-in specs.
    COLLECT_GCC=g++
    COLLECT_LTO_WRAPPER=/usr/lib/gcc/i686-linux-gnu/4.6/lto-wrapper
    Target: i686-linux-gnu
    Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.6.3-1ubuntu5' --with-bugurl=file:///usr/share/doc/gcc-4.6/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.6 --enable-shared --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.6 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --enable-plugin --enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i686 --with-tune=generic --enable-checking=release --build=i686-linux-gnu --host=i686-linux-gnu --target=i686-linux-gnu
    Thread model: posix
    gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
    @
    How can I fix these errors? thanks for any advice!



  • seems an error from compiler. Are u compile on 64 bit or 32 ?



  • It is a 32bit compiler.



  • I have managed to compile Qt5 from git after all. I have updated g++ to 4.7.3, that produced different assembler errors. I was executing make step as advised "here":http://qt-project.org/wiki/Building_Qt_5_from_Git: @make -j 4@
    I have also tried running just @make@ and that worked fine for me.
    But I have ended up with different error:
    @ld: cannot find -lQt5Designer@
    I have tried searching for libQt5Designer, but found only libQt5Designer.la and libQt5Designer.prl.
    Libraries i have needed to build seems to be fine, so I am marking post as solved.



  • Glad that u resolve it ...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.