Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

A simple console program "hello word" doesnt work!



  • Hi

    I have created a console program in plain c++ project with qmake . but it doesn't work true . the terminal window shows a empty context.

    !http://up.download.ir/di-DVIG.png(problem)!

    How can I correct it?



  • You can try with removing the console terminal to get the output in "Application Output" pane

    On the left panel Goto Projects-> Run Settings->Uncheck Run in Terminal.

    P.S

    The code works as intended.



  • Thanks dear!

    I did that But i get this result :

    !http://up.download.ir/di-HALB.png(pic)!

    I cant enter values for Cin function .



  • Hi!
    Check Options - >General - >System
    what settings are there?
    Probably it is relevant to "QTCREATORBUG-1633":https://bugreports.qt-project.org/browse/QTCREATORBUG-1633



  • isn't that bug... resolved?

    How bout a look into ur *.pro file? Maybe that can give us an idea on what's wrong with the application. In windows, a line

    @
    CONFIG += console
    @

    needed to be added for the terminal to display anything.

    Then again, you're using Ubuntu.



  • I think hor_313 use old Nokia QtSDK 1.2.1



  • This is the .pro file of my project image :

    !http://up.download.ir/di-3HWJ.png(pic)!

    I ran the OpenCV example and I could load an image in window but I couldnt show texts in terminal window



  • Did you check the settings?



  • [quote author="qxoz" date="1368782853"]Did you check the settings?[/quote]

    I cant find the general setting you said that



  • I use Qt 4.8 and ubuntu 12.04



  • is there any possibility that your "LIBS += ....." is wrong..
    because i did exactly with you except the LIBS+= stuff , and i got the correct result...



  • [quote author="hor_313" date="1368784889"]
    I cant find the general setting you said that[/quote]
    Tools - > Options – >Environment - > General – >System - > Terminal
    threre should be writen xterm -e

    [quote author="Ben__" date="1368785346"]is there any possibility that your "LIBS += ....." is wrong..
    because i did exactly with you except the LIBS+= stuff , and i got the correct result...[/quote]
    Wrong libs give a link errors.



  • [quote author="qxoz" date="1368789242"][quote author="hor_313" date="1368784889"]
    I cant find the general setting you said that[/quote]
    Tools - > Options – >Environment - > General – >System - > Terminal
    threre should be writen xterm -e

    [quote author="Ben__" date="1368785346"]is there any possibility that your "LIBS += ....." is wrong..
    because i did exactly with you except the LIBS+= stuff , and i got the correct result...[/quote]
    Wrong libs give a link errors.

    [/quote]

    !http://up.download.ir/di-QBNT.png(pic)!
    [quote author="qxoz" date="1368789242"][quote author="hor_313" date="1368784889"]
    I cant find the general setting you said that[/quote]
    Tools - > Options – >Environment - > General – >System - > Terminal
    threre should be writen xterm -e

    [quote author="Ben__" date="1368785346"]is there any possibility that your "LIBS += ....." is wrong..
    because i did exactly with you except the LIBS+= stuff , and i got the correct result...[/quote]
    Wrong libs give a link errors.

    [/quote]

    [quote author="qxoz" date="1368789242"][quote author="hor_313" date="1368784889"]
    I cant find the general setting you said that[/quote]
    Tools - > Options – >Environment - > General – >System - > Terminal
    threre should be writen xterm -e

    [quote author="Ben__" date="1368785346"]is there any possibility that your "LIBS += ....." is wrong..
    because i did exactly with you except the LIBS+= stuff , and i got the correct result...[/quote]
    Wrong libs give a link errors.

    [/quote]



  • Change x-terminal-emulator -e to xterm -e



  • I have changed it . this is the result :

    !http://up.download.ir/di-99KS.png(p)!



  • Unfortunately i am at user level on linux and can't say any useful advises about this error, but did you check is xterm present on you system?


Log in to reply