Qtwebkit webgl



  • So I feel pretty stupid but...

    How do you enable webgl using webkitview?

    I downloaded the QT creator OpenGL version, installed it, created a new HTML5 project, left it basic, ran fine. Added some simple JS code to check for webgl:
    if (!window.WebGLRenderingContext) {
    alert('No GL');
    return; }

                gl = canvas.getContext("webgl");   if (!gl) {
                    alert('GL Not Working');
                return;
                }
    

    No GL returned.

    Thought to myself there's something wrong so I copied and pasted webgl code from a website I know works on my Chrome browser, a simple wireframe cube, doesn't run.

    Added opengl to the config as I read somewhere that you have to have it enabled in the project, nothing.

    What am I missing?




Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.