[Solved]QT5 configure script problem in MinGW

  • Hi,

    On running the configure script for starting the build process i am getting the below error:

    Administrator@VALUED-7ZSFP29H ~/qt_repo/qt5 (stable)
    $ configure -developer-build -opensource -nomake examples -nomake tests

    • /c/Users/Administrator/qt_repo/qt5/qtbase/configure -developer-build -opensour
      ce -nomake examples -nomake tests

      The build script does not currently recognize all
      platforms supported by Qt.
      Rerun this script with a -platform option listed to
      set the system/compiler combination you use.

    *** qtbase/configure exited with non-zero status.
    Administrator@VALUED-7ZSFP29H ~/qt_repo/qt5 (stable)

    I tried setting the -platform as win32-g++ but that is causing the make program to crash.

    I am using MinGW 4.7.2 with Msys 1.0 on windows 7 32 bit.

    Can someone please guide me resolving the errir!

  • Moderators

    Hi kdk85,

    The 'configure' shell script doesn't work on Windows, even if you use MSYS. Run 'configure.bat' instead.

    Personally, I placed my MinGW 'bin' directory in my PATH, and always built Qt from cmd.exe instead of MSYS. I've never had any problems.

  • Thank you JKSH! I am able to configure now. Can you pls tell how to update the documentation "http://qt-project.org/wiki/Building_Qt_5_from_Git"!

  • Moderators

    You're welcome :)

    You can find the Wiki menu on the right of the wiki page, above your name. Click the Edit button.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.