Addin not visible in VS2012



  • Hi there,

    I recently upgraded to VS2012 so I installed Qt 5.0.2 and the VS add-in (1.2.1) on a few development machines and it worked like a charm. Today I tried installing it on an another machine and to my surprise there was no "QT5" menu in VS.

    I registered the addin manually, through Tools->Options->Environment->Add-in Security, adding the path to "C:\Program Files (x86)\Digia\Qt5VSAddin\11.0". After restarting VS2012, I got the "QT5" menu entry.

    The problem is, the Qt project templates are not available when I try to create a new Qt project. I was looking for a way to add them manually as well, but did not succeed.

    I suspect the problem is related to my running VS from a non-administrator account (all the other machines I was configuring and working from an administrator account). Is there any way to fix my VS configuration somehow? Thanks!


  • Moderators

    welcome to devnet

    [quote author="neuviemep" date="1366417287"]
    I suspect the problem is related to my running VS from a non-administrator account (all the other machines I was configuring and working from an administrator account). Is there any way to fix my VS configuration somehow?
    [/quote]

    AFAIK you need the admin rights when using visual studio. At least my old msvc2005 it displaying every time a message indicating so during start-up. I would expect that this is the same with msvc2012.

    Based on this I would check at first that there is no correlation with the missing admin rights.



  • [quote author="koahnig" date="1366456444"]welcome to devnet
    AFAIK you need the admin rights when using visual studio. At least my old msvc2005 it displaying every time a message indicating so during start-up. I would expect that this is the same with msvc2012.

    Based on this I would check at first that there is no correlation with the missing admin rights.
    [/quote]

    I don't think that's the issue, because I've been using VS2010 with Qt 4.8.0 and the 1.1.11 addin until now as the same non-admin user until now without a problem. Also, running VS2012 from the admin account doesn't help - the addin is still inactive until I add it through the manager, and the templates are unavailable as well after that.



  • Hi guys,

    I have same problem: from the usual User's account are not displayed the Qt templates in VS2012 solution browser.

    There is any a solution of this problem?

    PS: Windows 8 32bit, Qt 5.2.1, VS2012 Pro, Addin 1.2.2.




Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.