[SOLVED]Problem with Qt installation.



  • Hello, guys.
    I'm using Debian Squeeze 6.0.6 and GCC and G++ 4.4.5. I'm trying to install qt-linux-opensource-5.0.2-x86_64 and i'm having this error message:
    [quote]./qt-linux-opensource-5.0.2-x86_64-offline.run: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./qt-linux-opensource-5.0.2-x86_64-offline.run)
    [/quote]

    What can i do to solve this problem?

    Thank you.



  • Hi!
    Welcome to DevNet.
    As i know Qt 5 requires gcc 4.7, try update your gcc.


  • Moderators

    You can compile Qt yourself, then it won't complain for missing symbols. Qt can be compiled with any C++98 compliant compiler, so GCC 4.4 should work. Updating it to 4.7 or 4.8 is a good idea, too - you'll benefit from huge amount of optimisations, and C++11 support.



  • Ok, thank you, guys!
    I'll update my Gcc.

    Thanks for helping me.



  • I want to install qt in RHEL6.1 version.

    when I run the downloaded file

    ./qt-linux-opensource-5.0.2-x86-offline.run
    it gives this error::

    bq. ./qt-linux-opensource-5.0.2-x86-offline.run: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./qt-linux-opensource-5.0.2-x86-offline.run)

    and my RHEL contain GLIBC

    GLIBCXX_3.4
    GLIBCXX_3.4.1
    GLIBCXX_3.4.2
    GLIBCXX_3.4.3
    GLIBCXX_3.4.4
    GLIBCXX_3.4.5
    GLIBCXX_3.4.6
    GLIBCXX_3.4.7
    GLIBCXX_3.4.8
    GLIBCXX_3.4.9
    GLIBCXX_3.4.10
    GLIBCXX_3.4.11
    GLIBCXX_3.4.12
    GLIBCXX_3.4.13
    GLIBC_2.0
    GLIBC_2.3
    GLIBC_2.4
    GLIBC_2.1
    GLIBC_2.1.3
    GLIBC_2.3.2
    GLIBC_2.2
    GLIBCXX_FORCE_NEW
    GLIBCXX_DEBUG_MESSAGE_LENGTH

    how can I upgrade to GLIBCXX_3.4.15


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.