Examples won't compile...



  • Hi Folks,

    I've downloaded qt-linux-opensource-5.0.1-x86_64-offline and installed on my Ubuntu 12.04LTS system. I can run Qt Creator, but the examples won't compile. For example the Address Book example has this error:

    @20:37:46: Running steps for project addressbook...
    20:37:46: Configuration unchanged, skipping qmake step.
    20:37:46: Starting: "/usr/bin/make" -w
    make: Entering directory /home/mccall/Programming/Qt5.0.1/5.0.1/gcc_64/examples/widgets/itemviews/addressbook-build-Desktop_Qt_5_0_1_GCC_64bit-Debug' g++ -c -m64 -pipe -g -Wall -W -D_REENTRANT -fPIE -DQT_QML_DEBUG -DQT_DECLARATIVE_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I../../../../mkspecs/linux-g++-64 -I../addressbook -I../../../../include -I../../../../include/QtWidgets -I../../../../include/QtGui -I../../../../include/QtCore -I. -I. -o adddialog.o ../addressbook/adddialog.cpp In file included from ../../../../include/QtGui/qopenglcontext.h:60:0, from ../../../../include/QtGui/QtGui:33, from ../../../../include/QtWidgets/QtWidgets:5, from ../addressbook/adddialog.cpp:43: ../../../../include/QtGui/qopengl.h:99:21: fatal error: GL/gl.h: No such file or directory compilation terminated. make: *** [adddialog.o] Error 1 make: Leaving directory/home/mccall/Programming/Qt5.0.1/5.0.1/gcc_64/examples/widgets/itemviews/addressbook-build-Desktop_Qt_5_0_1_GCC_64bit-Debug'
    20:37:46: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project addressbook (kit: Desktop Qt 5.0.1 GCC 64bit)
    When executing step 'Make'@

    I do have libglu1-mesa installed already:

    @mccall@phenom:~/Programming/Qt5.0.1$ sudo apt-get install libglu1-mesa
    [sudo] password for mccall:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libglu1-mesa is already the newest version.@

    I guess I'm just missing a package, but I can't seem to work out which one! I found this "thread":http://qt-project.org/forums/viewthread/25501 that had the same problem, but the solution wasn't given...

    Please can someone help?



  • Doh! I didn't have the dev package!

    mccall@phenom:~/Programming/Qt5.0.1$ sudo apt-get install libglu1-mesa-dev

    All works as it should - thanks for looking anyway!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.