Login gmail problem



  • I have asked in [webkit-qt],Benjamin suggeste me to here.so I paste it
    my system qte4.5.1 on mips, openssl-0.9.7e,qte configure with "-openssl-linked "

    I have try https with "https://1984bbs.com" & "https://www.gmail.com",they all work fine.so my openssl worked,I think.
    but when I try to login gmail with my browser app.It failed with page refresh to login input one.So I tried these things.

    1.I tried to search help in google help.they told should enable cookie.

    2.I tried to use demo browser (qte supply).with cookie accept always in preferences -> Privacy.
    got cookies.ini like these,but cann't login in too.
    ~ # cat .qws/share/data/Trolltech/demobrowser/cookies.ini
    [General]
    cookies="@Variant(\0\0\0\x7f\0\0\0\x16QList<QNetworkCookie>\0\0\0\0\x17\0\0\0\x1b\0\0\0\x88__utma=173272373.400690153.1286447977.1286447977.1286447977.1;
    expires=Sat, 06-Oct-2012 10:39:36 GMT; domain=google.com;
    path=/accounts/\0\0\0k__utmb=173272373.0.10.1286447977; expires=Thu,
    07-Oct-2010 11:09:36 GMT; domain=google.com;
    path=/accounts/\0\0\0\x98__utmz=173272373.1286447977.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none);
    expires=Thu, 07-Apr-2011 22:39:36 GMT; domain=google.com;
    path=/accounts/\0\0\0\x89__utma=173272373.1431633522.1286447977.1286447977.1286447977.1;
    expires=Sat, 06-Oct-2012 10:39:37 GMT; domain=google.com;
    path=/accounts/\0\0\0k__utmb=173272373.0.10.1286447977; expires=Thu,
    07-Oct-2010 11:09:37 GMT; domain=google.com;
    path=/accounts/\0\0\0S__utmb=-; expires=Thu, 07-Oct-2010 11:09:37 GMT;
    domain=google.com;
    path=/accounts/\0\0\0\x89__utma=173272373.2112243659.1286447977.1286447977.1286447977.1;
    expires=Sat, 06-Oct-2012 10:39:37 GMT; domain=google.com;
    path=/accounts/\0\0\0k__utmb=173272373.0.10.1286447977; expires=Thu,
    07-Oct-2010 11:09:37 GMT; domain=google.com;
    path=/accounts/\0\0\0\x89__utma=173272373.1410256294.1286447999.1286447999.1286447999.1;
    expires=Sat, 06-Oct-2012 10:39:59 GMT; domain=google.com;
    path=/accounts/\0\0\0k__utmb=173272373.0.10.1286447999; expires=Thu,
    07-Oct-2010 11:09:59 GMT; domain=google.com;
    path=/accounts/\0\0\0\x98__utmz=173272373.1286447999.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none);
    expires=Thu, 07-Apr-2011 22:39:59 GMT; domain=google.com;
    path=/accounts/\0\0\0\x89__utma=173272373.1037594852.1286447999.1286447999.1286447999.1;
    expires=Sat, 06-Oct-2012 10:39:59 GMT; domain=google.com;
    path=/accounts/\0\0\0k__utmb=173272373.0.10.1286447999; expires=Thu,
    07-Oct-2010 11:09:59 GMT; domain=google.com;
    path=/accounts/\0\0\0S__utmb=-; expires=Thu, 07-Oct-2010 11:09:59 GMT;
    domain=google.com;
    path=/accounts/\0\0\0\x88__utma=173272373.236121215.1286447999.1286447999.1286447999.1;
    expires=Sat, 06-Oct-2012 10:39:59 GMT; domain=google.com;
    path=/accounts/\0\0\0k__utmb=173272373.0.10.1286447999; expires=Thu,
    07-Oct-2010 11:09:59 GMT; domain=google.com;
    path=/accounts/\0\0\0\x88__utma=173272373.438092326.1286448011.1286448011.1286448011.1;
    expires=Sat, 06-Oct-2012 10:40:11 GMT; domain=google.com;
    path=/accounts/\0\0\0k__utmb=173272373.0.10.1286448011; expires=Thu,
    07-Oct-2010 11:10:11 GMT; domain=google.com;
    path=/accounts/\0\0\0\x98__utmz=173272373.1286448011.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none);
    expires=Thu, 07-Apr-2011 22:40:11 GMT; domain=google.com;
    path=/accounts/\0\0\0\x89__utma=173272373.1246973853.1286448011.1286448011.1286448011.1;
    expires=Sat, 06-Oct-2012 10:40:11 GMT; domain=google.com;
    path=/accounts/\0\0\0k__utmb=173272373.0.10.1286448011; expires=Thu,
    07-Oct-2010 11:10:11 GMT; domain=google.com;
    path=/accounts/\0\0\0S__utmb=-; expires=Thu, 07-Oct-2010 11:10:11 GMT;
    domain=google.com;
    path=/accounts/\0\0\0\x88__utma=173272373.540263399.1286448011.1286448011.1286448011.1;
    expires=Sat, 06-Oct-2012 10:40:11 GMT; domain=google.com;
    path=/accounts/\0\0\0k__utmb=173272373.0.10.1286448011; expires=Thu,
    07-Oct-2010 11:10:11 GMT; domain=google.com;
    path=/accounts/\0\0\0\x90__utmz=108965826.1286449505.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none);
    expires=Thu, 07-Apr-2011 23:05:05 GMT; domain=1984bbs.com;
    path=/\0\0\0\x81__utma=108965826.1360561697.1286449505.1286449505.1286449505.1;
    expires=Sat, 06-Oct-2012 11:05:05 GMT; domain=1984bbs.com;
    path=/\0\0\0\x63__utmb=108965826.1.10.1286449505; expires=Thu,
    07-Oct-2010 11:35:05 GMT; domain=1984bbs.com; path=/)"

    [Exceptions]
    allow=@Invalid()
    allowForSession=@Invalid()
    block=@Invalid()

    3.in gmail setting I uncheck always use https,it worked,I login in gmail.And I founded
    http://mail.google.com/support/bin/answer.py?hl=en&answer=8155
    so I think my https worked.the demo browser use same qt library,cookie enable ok.
    why my login gmail with https failed all the time.

    BTW ,I add cookie supply with my browser app.same result.and qte4.6.1 ok.what's happened with qte4.5.1



  • Have you tried with a more recent version of WebKit? 4.7 or QtWebKit 2.1. That might be a bug that has been fixed.

    You should try investigate what is going on with the inspector. Maybe you'll find what is going on from the exchange of resources. It could be as simple as an encoding problem.

    The fact that the bug is on MIPS and not on the ARM and x86 could indicate a bug in Qt relative to the endianess.



  • to get QtWebKit 2.1 do I need to build Qt4.7.1 ?? or should I get it from webkit site?



  • The release branches are on git: http://gitorious.org/+qtwebkit-developers/webkit/qtwebkit
    For some reason, QtWebKit 2.1 has not been released yet. It is very stable already, I doubt much will change before the release.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.