[Solved] Error after Build: Qt 5.0.2 with Visual Studio 2012



  • Hello,

    I have Windows 8 64bit and I installed "qt-windows-opensource-5.0.2-msvc2012_64-x64-offline", "qt-vs-addin-1.2.0-opensource" and "Visual Studio Ultimate 2012 (x86) - Web Installer (German)". After creating a Qt Application in VS, I wanted to start the program (I just took the template from VS without any changes, so the program should work). I got the error "error LNK1112: module machine type 'x64' conflicts with target machine type 'X86'. C:\Users\Gina\Documents\Visual Studio 2012\Projects\Qt1\Qt1\Qt5Widgetsd.lib(Qt5Widgetsd.dll)".

    When I change Win32 to x64 in the configuration manager, I get this error: "there's no Qt version assigned to this project for platform x64 Please use the 'change the Qt version' feature and choose a valid Qt version for this platform."

    I thought that my Qt Version is 64bit? But in "About" in the Qt creator stands "based on Qt 5.0.2 (32bit)". So can I only create 32bit programs? And which configurations do I have to do to get no more errors? Change the module machine type to 'x86'? But how?

    Thank you for your help!


  • Moderators

    welcome to devnet

    Qt creator and the version it is build on and the actual Qt version you are using for building may be completely different. Qt creator is an IDE using Qt libs. msvc2012 is also an IDE using some ms libs. In both cases the version of libs the IDE is based is independent of what you use for applications.

    In the past Qt creator was often using an older version of Qt libs, when distributed in an SDK.

    Since you are using vsaddin there should be "Qt" menu and there is somewhere the possibility to change the Qt version. Unfortunately, I do not have msvc2012 installed nor the newest vsaddin installed. So I cannot guide you to the entry.



  • I've found it. Thank you!


  • Moderators

    You are welcome.
    I have marked your thread as solved then. Please do next time.



  • What a fuck.昨年、私はテーブルを買った
    [quote author="darkpearl" date="1365677101"]I've found it. Thank you![/quote]


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.