Qt 5.1 Alpha not building webkit



  • I've built Qt 4.x and 5.0 from source many many times. But this is puzzling. Qt 5.1 alpha is refusing to build webkit. The best part is there is no error, it just completes building everything except webkit.

    I'm on Windows with MSVC-2010 sp1. I cannot find any reference to webkit in 'configure -help' unlike previous versions where we had a -webkit option. Surely I'm missing something simple... Any ideas?



  • Still no luck. I've tried several configure options. Pretty much with the same effect:

    @..\src\configure -icu -mp -nomake tests -openssl -angle -c++11 -I C:\Qt\5.1-a1\icu-w32\include -I C:/Qt/5.1-a1/openssl-1.0.1c-x86/inc32 -L C:/Qt/5.1-a1/icu-w32\lib -L C:/Qt/5.1-a1/openssl-1.0.1c-x86/out32dll -opensource -platform win32-msvc2010@

    Output:

    @Configuration:
    minimal-config
    small-config
    medium-config
    large-config
    full-config
    pcre
    debug
    msvc_mp
    Qt Configuration:
    debug_and_release build_all release
    debug
    shared
    zlib
    icu
    angle
    png
    freetype
    build_all
    accessibility
    opengl
    opengles2
    egl
    openssl
    audio-backend
    native-gestures
    qpa
    concurrent
    minimal-config
    small-config
    medium-config
    large-config
    full-config

    QMAKESPEC...................win32-msvc2010 (commandline)
    Architecture................i386, features:
    Host Architecture...........i386, features:
    Maketool....................nmake
    Debug build.................yes (combined)
    Default build...............debug
    Force debug info............no
    C++11 support...............auto
    Link Time Code Generation...no
    Accessibility support.......yes
    RTTI support................yes
    SSE2 support................yes
    SSE3 support................yes
    SSSE3 support...............yes
    SSE4.1 support..............yes
    SSE4.2 support..............yes
    AVX support.................yes
    AVX2 support................no
    NEON support................no
    IWMMXT support..............no
    OpenGL support..............yes
    Large File support..........yes
    NIS support.................no
    Iconv support...............no
    Inotify support.............no
    Glib support................no
    CUPS support................no
    OpenVG support..............no
    OpenSSL support.............yes
    Qt D-Bus support............no
    Qt Widgets module support...yes
    QML debugging...............yes
    DirectWrite support.........no
    Use system proxies..........no

    Third Party Libraries:
    ZLIB support............qt
    GIF support.............plugin
    JPEG support............plugin
    PNG support.............yes
    FreeType support........yes

    PCRE support............qt
    ICU support.............yes
    ANGLE...................yes
    

    Styles:
    Windows.................yes
    Windows XP..............yes
    Windows Vista...........yes
    Fusion..................yes
    Windows CE..............no
    Windows Mobile..........no

    Sql Drivers:
    ODBC....................no
    MySQL...................no
    OCI.....................no
    PostgreSQL..............no
    TDS.....................no
    DB2.....................no
    SQLite..................plugin (qt)
    SQLite2.................no
    InterBase...............no

    Sources are in..............C:\Qt\5.1-a1\src\qtbase
    Build is done in............C:\Qt\5.1-a1\win32\qtbase
    Install prefix..............C:\Qt\5.1-a1\win32\qtbase
    Headers installed to........C:\Qt\5.1-a1\win32\qtbase\include
    Libraries installed to......C:\Qt\5.1-a1\win32\qtbase\lib
    Arch-dep. data to...........C:\Qt\5.1-a1\win32\qtbase
    Plugins installed to........C:\Qt\5.1-a1\win32\qtbase\plugins
    Library execs installed to..C:\Qt\5.1-a1\win32\qtbase\lib
    QML1 imports installed to...C:\Qt\5.1-a1\win32\qtbase\imports
    QML2 imports installed to...C:\Qt\5.1-a1\win32\qtbase\qml
    Binaries installed to.......C:\Qt\5.1-a1\win32\qtbase\bin
    Arch-indep. data to.........C:\Qt\5.1-a1\win32\qtbase
    Docs installed to...........C:\Qt\5.1-a1\win32\qtbase\doc
    Translations installed to...C:\Qt\5.1-a1\win32\qtbase\translations
    Examples installed to.......C:\Qt\5.1-a1\win32\qtbase\examples
    Tests installed to..........C:\Qt\5.1-a1\win32\qtbase\tests
    Include paths...............C:\Qt\5.1-a1\icu-w32\include C:/Qt/5.1-a1/openssl-1.
    0.1c-x86/inc32
    Additional libraries........-LC:/Qt/5.1-a1/icu-w32\lib -LC:/Qt/5.1-a1/openssl-1.
    0.1c-x86/out32dll@

    This builds:

    @Qt5CLucene.dll
    Qt5CLucened.dll
    Qt5Concurrent.dll
    Qt5Concurrentd.dll
    Qt5Core.dll
    Qt5Cored.dll
    Qt5Declarative.dll
    Qt5Declaratived.dll
    Qt5Designer.dll
    Qt5DesignerComponents.dll
    Qt5DesignerComponentsd.dll
    Qt5Designerd.dll
    Qt5Gui.dll
    Qt5Guid.dll
    Qt5Help.dll
    Qt5Helpd.dll
    Qt5Multimedia.dll
    Qt5Multimediad.dll
    Qt5MultimediaQuick_p.dll
    Qt5MultimediaQuick_pd.dll
    Qt5MultimediaWidgets.dll
    Qt5MultimediaWidgetsd.dll
    Qt5Network.dll
    Qt5Networkd.dll
    Qt5OpenGL.dll
    Qt5OpenGLd.dll
    Qt5PrintSupport.dll
    Qt5PrintSupportd.dll
    Qt5Qml.dll
    Qt5Qmld.dll
    Qt5Quick.dll
    Qt5Quickd.dll
    Qt5QuickParticles.dll
    Qt5QuickParticlesd.dll
    Qt5QuickTest.dll
    Qt5QuickTestd.dll
    Qt5Script.dll
    Qt5Scriptd.dll
    Qt5ScriptTools.dll
    Qt5ScriptToolsd.dll
    Qt5Sensors.dll
    Qt5Sensorsd.dll
    Qt5SerialPort.dll
    Qt5SerialPortd.dll
    Qt5Sql.dll
    Qt5Sqld.dll
    Qt5Svg.dll
    Qt5Svgd.dll
    Qt5Test.dll
    Qt5Testd.dll
    Qt5V8.dll
    Qt5V8d.dll
    Qt5Widgets.dll
    Qt5Widgetsd.dll
    Qt5Xml.dll
    Qt5Xmld.dll
    Qt5XmlPatterns.dll
    Qt5XmlPatternsd.dll@

    No errors during building...



  • From a helpful developer on IRC:

    This is a bug with shadow building on Windows. Building webkit in place seems to work.



  • deleted.



  • deleted.



  • OK finally managed to do a 5.1 Alpha shadow build. The biggest issue that was causing webkit not to build was a missing path to gnuwin32\bin inside the source tree. Adding that manually makes things work.

    @set PATH=C:\Qt\5.1-a\src\gnuwin32;%PATH%@

    My config:

    @..\src\configure -icu -mp -nomake tests -nomake demos -nomake examples -openssl -angle -I C:\Qt\5.1-a\icu-w32\include -I C:/Qt/5.1-a/openssl-1.0.1c-x86/inc32 -L C:/Qt/5.1-a/icu-w32\lib -L C:/Qt/5.1-a/openssl-1.0.1c-x86/out32dll -prefix [PERCENT]CD[PERCENT]\qtbase -opensource -platform win32-msvc2010 @

    (replace [percent] with the actual percent character, it's messing up the post)

    You'll get a qmldeclarative related error for a not-found module. Simply go into qtdeclarative/src/qmldevtools and type

    @nmake release@

    Go back up and continue the build. If you built with ICU you also manually need to place the ICU libraries into the qtbase\bin directory.

    After all that you'll end up with a fully built release.



  • I ran into a similar issue on OSX 10.8.2. The WebKit widget works but QtWebkit 3.0 does not. Application log says: "QtWebKit" is not installed.



  • I don't believe these are related. One way to check is to keep a very close eye on the compilation when webkit is building. It does it's requirements check in the middle of the whole Qt compile. Alternatively you could compile QtWebkit again by going into that directory and running make (or whatever you use).

    The issue above is specifically windows related though.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.