Where can I set the PATH of "Explorer Qt C++ examples:" for Qt Creator 2.1.0-Rc1?



  • In Qt Creator Getting started page, Examples area failicate user to "Choose an Example..." in
    "Explorer Qt C++ examples:". There are various Qt SDK & Nokia SDK 1.0 installed in my PC.
    Sometimes I wanna open the examples provided by Qt SDK 4.x , but sometimes I wanna see the examples in Nokia SDK.

    Where can I set the PATH of "Explorer Qt C++ examples:" so that I can switch the SDKs?



  • Follow this..I think this may help you...

    http://doc.qt.nokia.com/qtcreator-snapshot/index.html



  • Sorry, maybe I missunderstood what you want, but when I open an example in the next window I have to specify with which installed SDK I want to use it (you can set several). In Qt Creator you can add SDKs (which are used on that form) in Tools->Options on the Qt tab.



  • You can set the path for each project individually if you want, selecting the 'Projects' Tab and setting the Build/Execution Environment.
    In addition you can store this in a session. So when you open your 'Explorer Qt C++ examples' session for example - then you have always the correct paths set.
    Hope this comment was helpful!



  • Thank you guys. But the problem still exsits.

    I installed nokia sdk first, then install qt 4.7.1 desktop, and configure the mingw to the path of nokiaQtSDK. Installation guide force me to point the path of mingw(seems i haven't chances to reset it unless i unstall the sdk)

    When I open the "Qt 4.7.1 command prompt" under windows, The following messages show:
    Setting up a MinGW/Qt only environment...

    -- QTDIR set to C:\Qt\4.7.1
    -- PATH set to C:\Qt\4.7.1\bin
    *-- Adding C:\NokiaQtSDK\mingw\bin to PATH *
    -- Adding C:\WINNT\System32 to PATH
    -- QMAKESPEC set to win32-g++

    C:\Qt\4.7.1>

    Though I choose vesrion of 4.7.1 at VCsala mentioned next window, the build dir pointed to C:\NokiaQtSDK\mingw\bin. which my opened example still coming from "C:\NokiaQtSDK\Examples\4.6...". rather than "C:\Qt\4.7.1\examples..."

    Even though I store the Using System Environment and Set BUILDDIR to C:\Qt\4.7.1\examples... at Sliver mentioned area, still not work next time I opened the creator.



  • You have to store it as a session. When you next time load this session - then the path is already set correctly.

    Best regards


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.