Qt5 build from Git VS2010: Don't know how to make Qt5QmlDevTools.lib

  • I'm having troubles building Qt5 with Visual Studio 2010 x64 (stable branch clone of Qt5 git).

    The compiler gives the following error message:

    [quote]NMAKE : fatal error U1073: don't know how to make 'C:\Programs\Qt\qt5\qtbase\lib\Qt5QmlDevTools.lib'[/quote]

    My build setup:

    1. Install VS2010 Ultimate
    2. Install Windows 7.1 SDK
    3. Install DirectX SDK (June 2010)
    4. Run windows update, get various updates including VS2010 SP1
    5. Install msys git, python 3.3, ruby, strawberry perl
    6. Checkout Qt5 source, initialize submodules excluding qwebkit
    7. Configure Qt5 (VS2010 x64 command prompt):
      [quote]configure -debug-and-release -opensource -developer-build -mp -no-warnings-are-errors -confirm-license -nomake tests -nomake webkit[/quote]
    8. Build with nmake

    I've already checked to make sure sh.exe isn't in the search PATH, and a quick Google search hasn't brought up any useful information. I'm running Windows 7 x64.

  • I am having a similar issue. Is there a fix ?

  • I haven't found one yet.

  • Qt5QmlDevTools.lib is a dependency created by QmlDevTools.pro. Something is messed up with the build process. On Mac Qt is not properly creating Makefile.Release and Makefile.Debug for QmlDevTools.pro. I think this a build option that is broken for this pro. On PC these files are being generated but make (or jom) is not using them. Just cd into the QmlDevTools.pro dir and run make on the .Release and .Debug files.

    This has been an issue with stable for about 2 weeks now. Not sure why it hasn't been fixed.

  • the same issue, too.
    I'm running Windows XP (32bit), with Visual Studio 2010 SP1.

    configure using:
    configure -debug-and-release -opensource -opengl desktop -nomake tests -no-vcproj

    build using:
    jom\jom -j4

  • noticed "Note however, that it has issues with module interdependencies, which can cause builds to fail."
    I try build using:
    jom\jom -j1
    still failed.

    And I tried nmake also:

    NMAKE : fatal error U1073: don't know how to make 'D:\Qt\0407stable\qtbase\lib\Q
    NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 10.0\VC\BIN\nmake.exe"' : return code '0x2'
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    NMAKE : fatal error U1077: 'cd' : return code '0x2'

  • Hello. Kintoun's solution worked for me. Perhaps to make more clear what he meant (assuming your command line is in your Qt git repo clone root dir):

    @cd qtdeclarative\src\qmldevtools
    nmake debug
    nmake release

    Then go back and retry build on the whole thing:

    @cd ......

    Please use nmake instead of jom. jom tends to have dependency problems on complex projects (i.e. builds modules ahead of time when their dependencies are still not finished).

  • I used jom on machine A because I failed to install Windows SDK and nmake will fail and error info seemd related to Windows SDK.

    I used nmake on machine B, and got the same error with helloworld922.

    I'm trying this solution now, thank you :)

  • Build successfully (firstly build qmldevtools, then nmake), thank you :)

  • Hi, I had the same problem with Qt5QmlDevTools.lib. When nmake reported an error I went into qtdeclarative\src\qmldevtools and make nmake debug and release and then got back and run nmake again. But there is a new problem:

    bq. (set QT_PLUGIN_PATH=C:\Qt\qt-everywhere-opensource-src-5.1.0-alpha\qtbas
    opensource-src-5.1.0-alpha\qtmultimedia\plugins) & (set PATH=C:\Qt\qt-everywhere
    1.0-alpha\qtbase\lib;%PATH:)=^)%) & C:\Qt\qt-everywhere-opensource-src-5.1.0-alp
    ha\qtactiveqt\bin\dumpcpp.exe C:\WINDOWS\system32\ieframe.dll -o ieframe
    NMAKE : fatal error U1077: '(set' : return code '0xc000007b'
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 11.0
    \VC\BIN\nmake.exe"' : return code '0x2'

    Has someone got any idea why it behaves like that? Should I run nmake clean before or sth? I'm running Windows 8 x64.

    Configure Qt5 (VS2012 ×64 command prompt):

    bq. configure -developer-build -opensource -prefix C:\Qt\Qt5.1

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.