Error during installation process (qt.501.patcher) OS X 10.8.3

  • Hi:

    I downloaded qt-mac-opensource-5.0.1-clang-offline and I am running into an error that reads:

    Error during installation process (qt.501.patcher)
    Error while relocating Qt:Command install_name_tool failed
    Arguments: -change /Users/bld.qt/bamboo-agent-home/ etc etc etc

    I cannot find /Users/bld.qt on my Mac (running OS X 10.8.3). What am I doing wrong?

    The installation proceeded after I clicked "ignore", but I am running into the following error when I try to run a test case

    Starting /Users/sreenivas/Documents/Code/QTProjects/Test-build-Desktop_Qt_5_0_1_clang_64bit-Debug/
    dyld: Library not loaded: /Users/bld.qt/bamboo-agent-home/xml-data/build-dir/DQTC-RELEASE5LGPL-OSX106/PADDING/lib/QtWidgets.framework/Versions/5/QtWidgets
    Referenced from: /Users/sreenivas/Documents/Code/QTProjects/Test-build-Desktop_Qt_5_0_1_clang_64bit-Debug/
    Reason: image not found
    The program has unexpectedly finished.
    /Users/sreenivas/Documents/Code/QTProjects/Test-build-Desktop_Qt_5_0_1_clang_64bit-Debug/ exited with code 0

    Any help/pointer as to how I can get around this is greatly appreciated!



  • I thought I should provide a link to the error message window. I hope someone can help.

    "Link to the screenshot of the error message":

    I am trying to install the latest version on a Macbook Air OS X 10.8.3.

    Any help/pointers is greatly appreciated!


  • I got the same problem. The probably reason is uninstalling Qt5.0 not completely.

  • I've solved this problem by installing the Command Line Tools of Xcode. Why don‘t you have a try.

  • Xuefa -- Thanks for the help. Reinstalling the Command Line Tools of XCode did the trick for me.



Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.