Building Qt libraries for VS2012 runtime



  • Hi,
    I need to build and link the latest (5.0.1) Qt libraries against the VS2012 runtime libraries.
    I'm using the non-commercial Qt.

    Which package should I download and how do I configure it?
    Can I use the 'everywhere' package for that matter?

    Thanks,
    Gil.


  • Moderators

    welcome to devnet

    You need to download "Qt 5 from here":http://releases.qt-project.org/qt5/5.0.1/single/qt-everywhere-opensource-src-5.0.1.zip The zip has the line endings as required for windows.

    This is the wiki page for "building from Git":http://qt-project.org/wiki/Building-Qt-5-from-Git
    With Git would have access and be able to download the most recent development version, which you actually do not want to have. However, that you have already the code through the zip-file on your computer you may use the same guidelines. AFAIK there is not an updated wiki page for building Qt yet available. So, that might be the closest to come.
    The setup will contain a configure application helping to do the configuration.

    In addition this you should scan also this forum. There are several posts addressing possible issues with msvc2012, if they are still coming up.



  • You can either get the source code from git or download a zip package from the Downloads page. How to build Qt from source is explained "here":http://qt-project.org/wiki/Building_Qt_5_from_Git

    Edit: beaten by 5 seconds :p


  • Moderators

    [quote author="D0IT" date="1363893619"]
    Edit: beaten by 5 seconds :p[/quote]

    :D Plus a bit more text ;)



  • Hi, tried all kinds of things. Apparently there is no proper cookbook on how to configure and build for vs2012 compatibility.
    The problem I'm stuck on now is:

    @c:\qt5.0.1\qt-everywhere-opensource-src-5.0.1\qtbase\src\network\ssl\qsslsocket_openssl_p.h(66) : fatal error C1083: Cannot open include file: 'openssl/asn1.h': No such file or directory @

    My configure command line is:
    @configure –I C:\OpenSSL-Win32\include -opensource -openssl-linked -debug-and-release -platform win32-msvc2012 –no-icu -nomake examples -nomake tests@

    I couldn't find the include path mentioned in the created Makefile.

    Also tried to clean the configuration using 'nmake confclean' (suggested by 'Configure'), but there is no such file 'confclean'.

    Any help?



  • I guess that you did not install openssl library.

    If you want to support openssl, you must install openssl library and include its include and libary path in configure command options, such as:
    "configure -prefix C:\Qt\Qt5.0.1 -opensource -I D:\openssl-install-path\include -L D:\openssl-install-path\lib -lopenssllib"

    You can refer configure -help for sytax details.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.