[SOLVED]can't find the "src" directory to build my QPSQL driver



  • Hi k_arnaud, I will try to find more possible reasons for the message and come back with some new support.


  • Lifetime Qt Champion

    Currently, avoid spaces in path to libraries when developing. Or use the 8.3 names (you can check which one is correct using sir /x in a cmd prompt). To be on the safe side, reinstall PostgreSQL in a path without spaces. That will eliminate one possible source of problems. If the build fails again, then post the error log, it might give the clue to what you are missing.

    Also, ensure that you have a 32bit version of PostgreSQL installed since you are using the 32bit MinGW package.



  • Hi SGaist,
    i have a PostgreSQL 32bit installed. I try to instal an ohter, but the installer wizard doesn't allow me to choose my own directory, it updates the older which is in C:\Program Files (x86)\PostgreSQL... about to the error log, i don't know to post it. i think this site doesn't allow uploaded picture from computer ("i've printed my screen which shows the cmd with the error log")



  • You should uninstall your old version first and you can post a picture, too, if you use DropBox or similar. It's described "here: ":http://qt-project.org/wiki/ForumHelp#b642e0c67b7a32cc0b833ea119693dce



  • ok, thanks ! i built the plugin(the problem was from the old version of my PostgreSQL, i couldn't edit the .h file you talked about).now the new issue is that i get this error message "The specified path was not found" when i enter copy release\libqsqlpsql.a QTSDK_SQLDRIVERS_PATH... just a precision: those files are in C:\Qt\Qt5.2.1\5.2.1\Src\qtbase\plugins\sqldrivers and i think they have just been created.the modification date is today on 3 pm



  • The plugins are built in directories release and debug. I suggest to search for these directories and if you find the newly created DLLs there copy these to QTSDK_SQLDRIVERS_PATH. If there are issues again please post your environment (set > env.txt) and your error messages



  • Hi Clochydd,
    I didn't see the plugins in the directories named "release" and "debug", but i found them here(based on the creation date which was 03:04pm(it was 03:04pm when i built the plugins)): C\Qt\Qt5.2.1\Src\qtbase\plugins\sqldrivers and i copied them manually(Ctrl+C...) to QTSDK_SQLDRIVERS_PATH.... about the env.txt file, i can't find it. Thanks !



  • Hi k_arnaud,

    sorry, it should read: set > env.txt - this creates the file env.txt which contains the entries like PATH etc.
    You may do it by set and copy and paste, too.



  • Hi Clochydd,
    i think the right files are the files i talk about, you know, the file i've found here: C\Qt\Qt5.2.1\Src\qtbase\plugins\sqldrivers



  • I understand you moved these to QTSDK_SQLDRIVERS_PATH already.
    If it still does not work, you may try this:

    Create a directory sqldrivers** in your app-directory (where your application's exe-file will be built: eg.: myBUILD\Debug\sqldrivers).
    and copy the dlls to this directory.
    If this does not work, a look at your environment may be useful.



  • here is my env.txt file "env.txt...":https://www.dropbox.com/s/43kb0o8zqf8n4hm/env.txt



  • Hi k_arnaud, I've read through your env.txt and found this:

    1. your PostgreSQL is still in the directory with spaces: C:\Program Files(x86). You may work with it but you need to use 8.3 filenames then during the build process. You find the exact 8.3 names (eg. PROGR~2) with DIR /x.

    2. You must keep in mind, that environment variables declared by SET exist only as long as your current command window. You can always check their existence by using SET. Currently, your variables like QTSDK_SQLDRIVERS_PATH do not exist!



  • thanks ! but i uninstal the PostgreSQL of the Program Files (x86) directory, the new is here C:\psql. i think the content of "path" is not updated automatically



  • AFAIK the PATH variable will be updated during the install process.
    If you uninstalled your old PostgreSQL version, PATH should have been cleaned und updated by installing the one in C:\PSQL.



  • i installed the new manually, without the installer wizard because it doesn't allow me to choose a directory esle than C:\Program Files (x86).



  • And is your C:\Program Files (x86)\PostgreSQL empty now?
    It's important to have only one install or not to confuse multiple installs!



  • the uninstaller didn't work, so i deleted the directory manually, sorry



  • Unfortunately it's more difficult as it should now.
    Are you comfortable with modifying system settings under Windows?

    I think it will be easier to uninstall PostgreSQL again, delete all directories where both version were installed, install PostgreSQL again in the default directory and work with the 8.3 filenames.



  • Hi Clochydd,
    since PATH variable can't be updated automatically when you install a program manually, i do it myself, and it Work without problem(i don't see that error message again "Driver not loaded...").
    Now, i have to create all my destroyed databases(i forgot to save them before uninstalling the old version of PostgreSQL).some of them had more than thirty tables.What i hate in creating database is to create foreign keys,it is so redundant...Thank you for the time you've spent on this thread... I would like to keep talking with you.you can follow me on twitter @k_arnaud(search for Arnaud KADIO). Thanks! Thanks! Thanks!



  • Hi Arnaud, you are welcome!
    I'm glad I could help you a bit with that issue and hope to talk to you again.
    Please mark your thread as solved by editing your first post with a prepending [SOLVED] in the title.
    Have a nice day!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.