QML Desktop Component for Qt 5



  • Hi guys!

    Today I was try to upgrade QML Desktop Components on my computer and using the new version from dev branch. When I trying compiling it I receiving this errors:
    @
    /Volumes/Documents/PROJECTS/My Projects/GIT_IOS_5/QtProjects/QML Desktop Components/1.x/src/qtdesktop/qtmenu.cpp:98: error: 'class QPlatformMenu' has no member named 'setMinimumWidth'

    /Volumes/Documents/PROJECTS/My Projects/GIT_IOS_5/QtProjects/QML Desktop Components/1.x/src/qtdesktop/qtmenu.cpp:106: error: 'class QPlatformMenu' has no member named 'setFont'

    /Volumes/Documents/PROJECTS/My Projects/GIT_IOS_5/QtProjects/QML Desktop Components/1.x/src/qtdesktop/qtmenu.cpp:168: error: 'class QPlatformMenu' has no member named 'showPopup'
    @

    I try to find this method in class QPlatformMenu but this class doesn't have it. What I must do to fix this error? Thanks for any help.



  • did you check the requirements of the dev branch?



  • No, I don't see requirements. Where I may watch it? I using Tower it's a GIT client for mac I can't find this information in this app. Also, I check on github and also can't find it?



  • The dev branch requires Qt 5.1 (the dev branch of all Qt repos).



  • [quote author="frederik" date="1360885598"]The dev branch requires Qt 5.1 (the dev branch of all Qt repos).[/quote]

    Thanks for the information. I will waiting the Qt 5.1 release, and I will use in my projects the stable branch of repository.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.