Webview crash with google maps, QML bug or Webkit?



  • Hi all,

    I would like some advise about an issue I'm experiencing. Under linux (ubuntu 12.04) using 5.0.1, I'm getting a crash using the example application in webkit, minibrowser.

    If you navigate to "https://developers.google.com/maps/documentation/javascript/examples/":https://developers.google.com/maps/documentation/javascript/examples/ in the minibrowser app and zoom in and out, eventually the app crashes with a SegFault.

    Here is the stack trace :
    @0 ?? /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5WebKit.so.5 0xb60b187a
    1 ?? /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5WebKit.so.5 0xb60b1c92
    2 ?? /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5WebKit.so.5 0xb60b9112
    3 ?? /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5WebKit.so.5 0xb60b2a55
    4 ?? /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5WebKit.so.5 0xb60b72b9
    5 ?? /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5WebKit.so.5 0xb60b758f
    6 ?? /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5WebKit.so.5 0xb61e05ee
    7 QSGDefaultRenderer::renderNodes(QSGNode* const*, int) /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5Quick.so.5 0xb7d679ad
    8 QSGDefaultRenderer::render() /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5Quick.so.5 0xb7d6849c
    9 QSGRenderer::renderScene(QSGBindable const&) /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5Quick.so.5 0xb7d6ee57
    10 QSGRenderer::renderScene() /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5Quick.so.5 0xb7d6efbd
    11 QSGContext::renderNextFrame(QSGRenderer*, unsigned int) /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5Quick.so.5 0xb7d7a4ae
    12 QQuickWindowPrivate::renderSceneGraph(QSize const&) /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5Quick.so.5 0xb7daf2b4
    13 ?? /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5Quick.so.5 0xb7eadfa9
    14 ?? /home/touch/Qt5.0.1/5.0.1/gcc/lib/libQt5Core.so.5 0xb542fa47
    15 start_thread /lib/i386-linux-gnu/libpthread.so.0 0xb40b3d4c
    16 clone /lib/i386-linux-gnu/libc.so.6 0xb51e7d3e
    @

    I tested it with the browser (widget version) and it worked all ok. Believe that uses webkit1 whereas the minibrowser uses webkit2.

    I also tested it on a Mac and that worked all ok in the mini browser.

    I have tried to get a git version of Qt working but haven't had much success yet.

    I'm not sure if it's a qml bug, webkit bug or something related to linux? I was going to post a bug report on webkit but the more I think about it the less I can pin point where the problem is.

    I would be grateful for some advice on what to do next?



  • Just an update.

    Is there any magic to getting the debug version of webkit? Got Qt compiled with developer-build but can't get Webkit to work to try and debug. QML keeps saying it can't find webkit.

    Any ideas?



  • Were you able to resolve this? We have a similar issue with Qt (5.x up to 5.3.2 currently) QWebView displaying Google Maps in a desktop app. Crash occurs on OS X and Windows, usually triggered by zooming.

    Cheers!



  • Hi!

    Have anyone been able to solve this? I have the same problem.

    [0914/185750:ERROR:texture_manager.cc(1699)] [.RenderCompositor-004B7E70]GL ERROR :GL_INVALID_ENUM : glTexImage2D: <- error from previous GL command
    [0914/185755:ERROR:gles2_cmd_decoder_autogen.h(1105)] [.Offscreen-MainThread-06242AA0]GL ERROR :GL_INVALID_ENUM : GetIntegerv: <- error from previous GL command
    [0914/185755:FATAL:program_manager.cc(255)] Check failed: max_len == 0 || len < max_len.

    the problem is only when I try to open google maps, but is exactly google maps that I want to use. When I try with a simple WebView, GoogleMaps runs in lite mode.

    Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.