[SOLVED]trouble with compiling on qt creator

  • I installed "Qt libraries 4.8.4 for Windows (VS 2010, 234 MB)" and "Qt Creator 2.6.2 for Windows (51 MB)".

    I got the following compile output:
    @09:52:13: Running steps for project qttest...
    09:52:13: Configuration unchanged, skipping qmake step.
    09:52:13: Starting: "C:\Qt\qtcreator-2.6.2\bin\jom.exe"
    C:\Qt\qtcreator-2.6.2\bin\jom.exe -f Makefile.Debug
    link /LIBPATH:"c:\Qt\4.8.4\lib" /NOLOGO /DYNAMICBASE /NXCOMPAT /DEBUG /MANIFEST /MANIFESTFILE:"debug\qttest.intermediate.manifest" /SUBSYSTEM:WINDOWS "/MANIFESTDEPENDENCY:type='win32' name='Microsoft.Windows.Common-Controls' version='' publicKeyToken='6595b64144ccf1df' language='' processorArchitecture=''" /OUT:debug\qttest.exe @C:\Users\owner\AppData\Local\Temp\qttest.exe.5484.31.jom
    LINK : fatal error LNK1104:
    jom: C:\Users\owner\Desktop\qttest-build-??????-Debug\Makefile.Debug [debug\qttest.exe] Error 1104
    jom: C:\Users\owner\Desktop\qttest-build-??????-Debug\Makefile [debug] Error 2
    09:52:13: The process "C:\Qt\qtcreator-2.6.2\bin\jom.exe" exited with code 2.
    Error while building/deploying project qttest (kit: Desktop)
    When executing step 'Make'@

    does anyone know how to solve this problem?

    I am using Windows 7 64 bit and Visual C++ 2010 express.

  • Moderators

    Those question marks in shadow build dir look strange. What is the name of your kit? Does it contain UTF-8 characters?

  • Thank you for your reply.
    this proplem has now been solved!
    This problem was caused by the lack of "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin;C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE" in "PATH" env var.

  • Moderators

    tobtbor: Actually Creator should have added that itself, provided you did select the correct compiler...

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.