[SOLVED]Unable to find a Qt build! To solve this problem specify a Qt build



  • Operating System: Windows 8
    Qt Version: 5.0.1 (MinGW 4.7)
    IDE: Visual Studio 2010

    Hi,

    I am trying to get Qt working within Visual Studio 2010.

    I installed Qt and then the Visual Studio Add-in. Everything works find in the Qt Creator, although when I try and setup a new project in Visual Studio I get the following error: Unable to find a Qt build! To solve this problem specify a Qt build.

    I have looked around and can't find a solution.

    Can anyone help?

    Thanks

    Jay


  • Moderators

    You cannot mix MinGW and MSVC builds, they are not binary compatible. Download Qt for MSVC 2010 in order to use it in MS VS.



  • Hi, thanks for the reply.

    I tried MSVC build and that gave me the same error.



  • I solved the issue, I had to select the build in the options menu.

    Jay



  • Hi Jay,
    Can you state more clearly how you selected the build in the option menu!
    Thanks!
    Best regards,
    Bent



  • I got the same error and noticed if you cancel out of the project creation, there should now be a Qt menu in Visual Studio. Click that, then Qt Options, and you can add a version in there.



  • Im posting this so that anyone looking for an answer to this in the future can be helped out. You need to give visual studio the path to qmake.exe. So you need to install the qt-windows-opensource-5.2.0-msvc2010-x86-offline.exe package. Once this package is installed go to the Qt menu in visual studio and click on Qt Options. In the Qt versions tab click on the add button on the right hand side and then within the path browser that you see, select one directory above the /bin directory within your Qt5.2.0 installation which typically has the path of C:\Qt\Qt5.2.0\5.2.0\msvc2010 unless you have changed it to something else during the installation of the package mentioned above. Once this directory is selected qmake.exe is found and now you can create qt projects and build them. Hope this helped.



  • @adithyak, thanks, that helped a lot!



  • @adithyak thanks a lot, that was helpful!



  • @JayWeb Thank you for the solution, I solved the problem in Visual Studio 2015 (x64 with the last updates) by selecting the build in the options menu and I'm using 5.7 version by the way.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.