QtCreator under WINE crashes when editing QML files.



  • Hello.
    I would like to develop for Symbian from an Ubuntu system. I used to be able to do this with the Remote Compiler service before it was closed down. I can use the Nokia SDK 1.2.1 on Windows of course, but here I am interested in using Ubuntu, and so I have tried this same 1.2.1 SDK under Wine 1.5, on Ubuntu 12.04.
    (I realise that there is also an experimental symbian-supporting linux SDK available, but I have had trouble with that too, but I won't expand on that here).

    I can start QtCreator (2.4.1) OK under wine, and I can create for example a hello world project – e.g. the default QtQuick project which QtCreator generates for you – and I can build this for a Symbian target. I get a .sis file generated, and I can transfer this to my mobile (N8) where it runs OK. So far so good.

    The trouble starts when I attempt to edit this project. If I have recently created this project from the QtCreator wizard (during the same session of QtCreator) then I can add new files, edit existing files, create new .sis packages and so on.

    If however I load up a previously created project – even if it is an un-edited wizard-created sample project – wine crashes whenever I attempt to save an edited QML file. This happens to both new QML files added to the project, and to any of the wizard-created QML files. Any sort of edit to the file - even just adding a space - leads to a crash when I attempt to save the edited file. Editing C++ files does not cause this problem.

    Wineserver crashes (and QtCreator freezes), and apport reports a segfault including:

    @source .... not located in a known VMA region (needed readable region)!@

    Just to repeat: the problem does not happen with QML files from newly created projects; it happens with existing projects loaded into QtCreator; and only QML files appear to cause the problem.

    Can anybody help?


  • Moderators

    I am not aware of anybody ever tried running creator in wine before:-) Do you have a backtrace?

    Does this happen on normal windows, too?



  • it might be better to aim to have only the symbian tools run under wine, and not creator.
    That will require some custom hacking to get stuff working, maybe some command-line only stuff... But I think you'll have a much higher chance of success if you do ;)
    Just a thought.



  • @Tobias - no, this does not happen under Windows. Backtrace info to follow.



  • I have posted a description of the problem on the WineHQ forums, where I've listed the backtrace and terminal output:
    http://forum.winehq.org/viewtopic.php?f=8&t=18283


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.