[Qt Creator] Tilde key doesn't work



  • Hi,

    Since Qt 5.0 the tilde key doesn't work anymore in the text editor (on Win 7 64bits).
    I have a french keyboard layout and I have to enter the sequence Alt Gr + 2 then SPACE key to display the tilde.
    Expected outcome: ~ character on its own
    Actual behavior: SPACE character on its own

    At the moment I go to notepad and copy paste the character when I need it.

    Is there a workaround or setting I missed?

    Help appreciated, this is quite ennoying...



  • To me, it sounds as if the windows keyboard layout that you have set for QtCreator is off. Windows keeps track of the keyboard layout per application, at least while running. Pressing CTRL+SHIFT switches the active layout. Could you try that?



  • Hi AndrĂ©, I tried that but it didn't work. Also I have only one keyboard layout installed on windows so not sure what would be the expected outcome.

    This being said, I found a clue:

    • go in Tools / Options
    • Pick "Text editor" in the left list
    • Go to "Completion"
    • Change option Activate completion: from Always to Manually

    Now the tilde is visible!

    Is there a way to alter the behavior of this autocompletion tool?



  • Ok, sorry, then I don't know. Sorry to have led you down the wrong path.



  • No worry, appreciate the attention.



  • Hi,

    It seems that I've got the same problem here (Qt Creator 3.1.1.) on OS X 10.9.4.
    I've a French keyboard and the ~ and ^ are working strangely. But I found something...

    When the problem occurred try to switch application (like open Safari for while) and tilde comes back in Qt Creator !
    Yes it will not resolve the issue, but it's better than copy/paste a ~ from notepad ;-)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.