ICU Problems building QT 5.0.1 64 bit



  • I have followed "this guide":http://www.holoborodko.com/pavel/2011/02/01/how-to-compile-qt-4-7-with-visual-studio-2010/#comment-7546
    to build Qt 5.0.1 for 64 bit windows and I am getting a linker error for ICU. Specifically that it cannot find the file specified. The file is in fact in the ICU\include directory and I made the necessary changes to the qmake.conf file:

    I changed QMAKE_CFLAGS = -nologo -Zm200 -Zc:wchar_t
    to
    QMAKE_CFLAGS = -nologo -Zm200 -Zc:wchar_t /I”C:\icu\include”

    But it has made no difference.

    I am using nmake instead of jom but it appears to be completely ignoring that flag.

    Can someone (a wiser person than I) please tell me if I have done something stupid?

    The specific error is:

    @tools\qlocale_icu.cpp(48) : fatal error C1083: Cannot open include file: 'unicod
    e/uloc.h': No such file or directory@

    Thanks in advance.

    Tanya



  • Have you used parameters like below when you did configure ?

    -icu -I C:\Libs\icu\include -L C:\Libs\icu\lib64



  • Thanks for the rapid response!

    Those parameters are actually in the qmake.conf file (as per the guide). The directories on my machine are the same as the guide. i.e

    c:\icu\include
    c:\icu\lib64



  • I think that to edit qmake.conf is not right.
    I used parameters above with configure and had no issues with compilation. At least it is documented way to do this.



  • I will try it the way you suggest now. If this is true then I wonder why I am having problems but the author of the guide (and other people) are not. Maybe it is something weird in my set up that I dont know about.

    Tanya



  • Are you using Visual Studio's compilers? What version? The link you have provided above is guide for VS 2010. If you use different version it will not work. It is why to use configure parameters is more right.



  • Ok, now this is baffling. I added the -I c:\icu\include and -L c:\icu\lib64 to the configure command line, but I am still getting:

    @tools\qlocale_icu.cpp(48) : fatal error C1083: Cannot open include file: 'unicod
    e/uloc.h': No such file or directory@

    That surely should have fixed the problem. The file is where it is supposed to be (c:\icu\include\unicode\uloc.h) so there must be another problem preventing nmake from seeing it. Could this be a bug or is it still likely I have done something stupid?



  • [quote author="serg675" date="1359930580"]Are you using Visual Studio's compilers? What version? The link you have provided above is guide for VS 2010. If you use different version it will not work. It is why to use configure parameters is more right.[/quote]

    I am using VS2010.



  • Even weirder....when I leave out the -icu option in configure, it STILL stops on the same error, even after Ive done a nmake clean. This really has me stumped now.



  • You have to do nmake distclean.
    Otherwise you configuration is still the same since clean removes binaries only.
    I suggest you to start from scratch. I mean to delete everything and unzip pure sources again.



  • Serg, thanks for replying. I will do as you suggested and let you know how it works out.

    Thanks

    Tanya



  • Is this problem has been solved?
    i have a same problem like this
    i'm trying to build qt 5.4.0 but failed everytime, and had same error message like
    'c:\qt\5.4.0\qtbase\src\corelib\tools\qcollator_p.h(52) : fatal error C1083: Cannot open include file: 'unicode/ucol.h': No such file or directory',
    'c:\qt\5.4.0\qtbase\src\corelib\tools\qtimezoneprivate_p.h(53) : fatal error C1083: Cannot open include file: 'unicode/ucal.h': No such file or directory'
    'tools\qlocale_icu.cpp(40) : fatal error C1083: Cannot open include file: 'unicode/uloc.h': No such file or directory'
    can anyone give me some help or advice?



  • Is this problem has been solved?
    i have a same problem like this
    i'm trying to build qt 5.4.0 but failed everytime, and had same error message like
    'c:\qt\5.4.0\qtbase\src\corelib\tools\qcollator_p.h(52) : fatal error C1083: Cannot open include file: 'unicode/ucol.h': No such file or directory',
    'c:\qt\5.4.0\qtbase\src\corelib\tools\qtimezoneprivate_p.h(53) : fatal error C1083: Cannot open include file: 'unicode/ucal.h': No such file or directory'
    'tools\qlocale_icu.cpp(40) : fatal error C1083: Cannot open include file: 'unicode/uloc.h': No such file or directory'
    can anyone give me some help or advice?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.