Setup on K-Ubuntu



  • I'm trying to install Qt 4.8 in Kubuntu.

    ./configure
    Creating qmake. Please wait...
    make: Nothing to be done for `first'.
    Basic XLib functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in /media/HD2/4.8/qt-everywhere-opensource-src-4.8.4/mkspecs/linux-g++.

    What should I install?
    I installed without solving the problem::
    libx11-xcb1
    libx11-xcb1-dbg
    libx11-xcb-dev
    libx-xcb-dev
    libxcb1-dev


  • Moderators

    @
    sudo apt-get build-dep qt-sdk
    @



  • apt-get successful.
    Restarted kubuntu.
    . / configure does not install Qt.

    user@ubuntu:/media/HD2/4.8/qt-everywhere-opensource-src-4.8.4$ ./configure
    Which edition of Qt do you want to use ? o
    Do you accept the terms of either license? yes

    Creating qmake. Please wait...
    make: Nothing to be done for `first'.
    Basic XLib functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in /media/HD2/4.8/qt-everywhere-opensource-src-4.8.4/mkspecs/linux-g++.


  • Moderators

    Never got that kind of error, so I'll continue shooting blanks :) Qt4 does not use XCB, though, as far as I remember.
    @
    sudo apt-get duild-dep libqt4-dev
    cd your/qt/source/code
    export QTDIR=
    export PATH=$PWD/bin:$PATH
    ./configure -opensource -confirm-license
    @

    Also, if you are not using git, make sure to download the tarball, not .zip.



  • Ok, after the make I have this errors:

    g++: error: unrecognized command line option ‘-fuse-ld=gold’
    g++: error: unrecognized command line option ‘-fuse-ld=gold’
    g++: error: unrecognized command line option ‘-fuse-ld=gold’
    make[2]: *** [../../../../../../lib/libQtWebKit.so.4.9.3] Error 1
    make[2]: Leaving directory /media/HD2/4.8/qt-everywhere-opensource-src-4.8.4/src/3rdparty/webkit/Source/WebKit/qt' make[1]: *** [sub-WebKit-qt-QtWebKit-pro-make_default-ordered] Error 2 make[1]: Leaving directory/media/HD2/4.8/qt-everywhere-opensource-src-4.8.4/src/3rdparty/webkit/Source'
    make: *** [sub-webkit-make_default-ordered] Error 2



  • I would guess your gcc is too old for webkit,
    you can try to reconfigure passing the configure option to disable webkit.
    -no-webkit


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.