Qt5 configure error



  • I use Linux Mint. I want to compile Qt dbus module. So, I configure:
    ../configure -prefix $KF5 -opensource -confirm-license -nomake examples -nomake tests -nomake webkit -make qtdbus -qpa xcb -no-gtkstyle -qt-xcb

    And I get:
    Warning: Disabling Linux Accessibility Bridge: DBus is missing.
    ...
    QtDBus module .......... no

    What's wrong?



  • So, these are new messages:

    ../configure -prefix $KF5 -opensource -confirm-license -nomake examples -nomake tests -nomake webkit -dbus -qpa xcb -no-gtkstyle -qt-xcb

    The QtDBus module cannot be enabled because libdbus-1 version 0.93 was not found.
    Turn on verbose messaging (-v) to /home/denis/qt5/qtbase/configure to see the final report.
    If you believe this message is in error you may use the continue
    switch (-continue) to /home/denis/qt5/qtbase/configure to continue.
    *** qtbase/configure exited with non-zero status.

    I tried:
    sudo apt-get install libdbus-1*
    but got the same.



  • Hi,

    Had the same problem and after instaling libdbus-1-dev the problem got solved


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.