QtGUI do not want to be build



  • My configuration line is:
    configure -platform win32-msvc2012 -mmx -sse2 -openssl -confirm-license -debug-and-release -opengl-es-2 -openvg -no-s60 -qt-zlib -qt-libpng -qt-libtiff -qt-libjpeg -webkit -opensource -shared -no-ltcg -qt-sql-sqlite -no-qt3support -mp -nomake examples -nomake tests -I C:/SDKs/openssl-1.0.1c/include -L C:/SDKs/openssl-1.0.1c/lib -I C:\SDKs\icu\dist\include -L C:\SDKs\icu\dist\lib -I C:\SDKs\angle\trunk\include -L C:\SDKs\angle\trunk\lib -D GLEW_STATIC

    However it is not possible to build qt due to the line in file gui.pro:
    include(egl/egl.pri)
    win32:!wince*: DEFINES += QT_NO_EGL

    Since opengl is defined: egl is defined too therefore files: egl/qegl.cpp and egl/qeglproperties.cpp
    are scheduled for compilation, but it is impossible to have these to files compiled with define QT_NO_EGL.
    What i'm doing wrong?

    I'm using latest source from git.
    Unfortunately i want openVG support and openl gl es 2 or desktop. Of cause there is always an option to use third party library, but it's kinda silly to use it if it is already present in qt.



  • -There is no such code in "gui.pro":http://qt.gitorious.org/qt/qtbase/blobs/dev/src/gui/gui.pro.-

    You are talking obviously about Qt4 here.

    I actually don't know if there is OpenGL ES support in Qt4 other than for the WindowsCE platform.



  • Ok. I've switched to Qt5. Compilations succeeded. I've taked about QT 4.8


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.