Qt5 Installation Problem.



  • Can Qt5 be installed on CentOS 5 and CentOS 6?


  • Moderators

    As long as it has OpenGL, ICU, and a working ISO C++98 compiler, it should be possible.



  • Hi,

    Thanks for the reply.
    I tried to compile Qt5 from source on CentOS-5.8 but it failed with errors listed below,

    @opengl/qopengl.cpp: In constructor 'QOpenGLExtensionMatcher::QOpenGLExtensionMatcher()':
    opengl/qopengl.cpp:77: error: 'GL_NUM_EXTENSIONS' was not declared in this scope

    make[3]: *** [.obj/debug-shared/qopengl.o] Error 1
    make[3]: Leaving directory /setups/qt-everywhere-opensource-src-5.0.0/qtbase/src/gui' make[2]: *** [sub-gui-make_first] Error 2 make[2]: Leaving directory/setups/qt-everywhere-opensource-src-5.0.0/qtbase/src'
    make[1]: *** [sub-src-make_first] Error 2
    make[1]: Leaving directory `/setups/qt-everywhere-opensource-src-5.0.0/qtbase'
    make: *** [module-qtbase-make_first] Error 2
    @

    When I tried to install Qt5 on CentOS-6.3 with the installer, but it too failed with the following error,

    @./qt-linux-opensource-5.0.0-x86-offline.run: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./qt-linux-opensource-5.0.0-x86-offline.run)@

    Can you help me figure out this problem.


  • Moderators

    Take a look at dependencies and instructions in this "guide":http://qt-project.org/wiki/Building_Qt_5_from_Git (esp. mesa packages should be of interest to you). I'm not using CentOS, so it's hard for me to be more specific. I've compiled Qt5 on Kubuntu numerous times with both GCC and clang, if that is any help.

    Actually if you manage to get it working, you can modify the wiki page and include your findings.



  • Hi,

    I have managed to install Qt5 on CentOS 6.3 using the installer.

    But on CentOS 5.8 it still fails. I have also installed all the mesa packages that were available for CentOS, then too the error is not going. The package I cannot found for CentOS were xcb-util-wm, xcb-util-wm-devel, xcb-util-image, xcb-util-image-devel, xcb-util-keysyms, xcb-util-keysyms-devel.


  • Moderators

    Now that is not good. XCB is needed the official QPA plugin (Qt Platform Plugin) for X11. There other alternative is Wayland, or possibly linuxFB, but I have no experience in either of them, sorry.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.